Abyss not sending close_notify

 
Post new topic   Reply to topic    Aprelium Forum Index -> FastCGI/CGI
View previous topic :: View next topic  
Author Message
Paulie
-


Joined: 20 Feb 2016
Posts: 6

PostPosted: Sun May 03, 2020 3:29 pm    Post subject: Abyss not sending close_notify Reply with quote

When sending POST data to a CGI running on Abyss using libcurl and Abyss is setup to redirect everything to https, the CGI fails with this data returned...
Quote:
User-Agent: Mozilla/5.0 Gecko/41.0 Firefox/41.0
Accept: */*
Content-Length: 9
Content-Type: application/x-www-form-urlencoded

* upload completely sent off: 9 out of 9 bytes
* Mark bundle as not supporting multiuse
< HTTP/1.1 200 OK
< Content-type: text/html
< Connection: Close
< Date: Fri, 24 Apr 2020 18:34:04 GMT
< Server: Abyss/2.11.8-X2-Win32 AbyssLib/2.11.8
<
* schannel: server closed abruptly (missing close_notify)
* Closing connection 0
* schannel: shutting down SSL/TLS connection with mydomain.com port 443

Should Abyss not be sending close_notify to be TLS compliant?
When using schannel, it doesn't allow abrut disconnect as it could generate an attack.

https://github.com/curl/curl/issues/4427
Back to top View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> FastCGI/CGI All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group