Problems installing ASP

 
Post new topic   Reply to topic    Aprelium Forum Index -> Classic ASP
View previous topic :: View next topic  
Author Message
Deasign
-


Joined: 18 Nov 2004
Posts: 4

PostPosted: Thu May 25, 2006 11:28 pm    Post subject: Problems installing ASP Reply with quote

Hello. I have problems installing ASP on my new laptop. I've followed the steps and everything seems fine until I change the server root from D:\Abyss Web Server to D:\Pages.

When I change the icon in the tray bar flashes red and the status in the host table says "Error". It says running until I change the server root.

When I visit 127.0.0.1 I get the "Welcome to Abyss Web Server"-message.

This is what the console is saying:
-- Default host on port 80 has errors and is stopped (Local URL http://127.0.0.1)
Can't find the file. (key: root/server/host/scripting/cgi/errorfile - file: D:\Abyss Web Server\abyss.conf - line: 48 - col: 5)
Error while reading/setting the configuration of module scripting (key: root/server/host/scripting/cgi/errorfile - file: D:\Abyss Web Server\abyss.conf - line: 48 - col: 5)
Console local URL: http://127.0.0.1:9999

Why doesn't it work? Is it because I installedthe server on D or is it because I installet AHTMl inside the Abyss webserver-directory??
Back to top View user's profile Send private message
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3719
Location: USA, GA

PostPosted: Fri May 26, 2006 3:05 am    Post subject: Reply with quote

You need to move the files from D:\Abyss Web Server to D:\Pages.

Do you mean the Documents Path? In that case don't even touch the Server
Root settings. Go to {Host} Configure -> General.
_________________
Computer Programmer & Networking Specialist

Back to top View user's profile Send private message Visit poster's website MSN Messenger
Deasign
-


Joined: 18 Nov 2004
Posts: 4

PostPosted: Fri May 26, 2006 9:36 am    Post subject: Reply with quote

I just want to change the root. So I don't have to browse to my Webpage-directory. Want the server to start there, and when I type 127.0.0.1 in the webpage-directory will show up. Do you understand what I mean?

I try do do this by:
Server Configuration -> Parameters -> Server root: D:\Pages

I have another question. I read something about abyss not supporting AMD Turion 64, is that correct? Or does it just not support it 100%?
Back to top View user's profile Send private message
AbyssUnderground
-


Joined: 31 Dec 2004
Posts: 3855

PostPosted: Fri May 26, 2006 9:51 am    Post subject: Reply with quote

Abyss supports all processors. Where did you read this?

Abyss will run on 64 bit machines but it will only run using 32 bits until aprelium has recompiled it for 64 bit.
_________________
Andy (AbyssUnderground) (previously The Inquisitor)
www.abyssunderground.co.uk
Back to top View user's profile Send private message Visit poster's website
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Fri May 26, 2006 10:50 am    Post subject: Reply with quote

Deasign wrote:
I just want to change the root. So I don't have to browse to my Webpage-directory. Want the server to start there, and when I type 127.0.0.1 in the webpage-directory will show up. Do you understand what I mean?

I try do do this by:
Server Configuration -> Parameters -> Server root: D:\Pages


If you want your web site pages to be in D:\Pages, change only the Documents Path value in Console > Hosts - Configure > General .

If you want to change the root, you'll have to create a new subdirectory called log inside the new root. The lack of this directory is what caused the error to be displayed (the server was unable to create the log files).

Quote:
I have another question. I read something about abyss not supporting AMD Turion 64, is that correct? Or does it just not support it 100%?


Where have you read that? Abyss Web Server works on any Intel 32bit processor or compatible including the AMD Turion 64.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
Deasign
-


Joined: 18 Nov 2004
Posts: 4

PostPosted: Fri May 26, 2006 4:29 pm    Post subject: Reply with quote

Thank you, it seems to work now.
It's just one thing that isn't working:

I have a network (my laptop and my stationary computer). On my stationary I've got my web pages-directory. So I have shared the directory on the network to be able to change and work the files from any computer connected to the network.

I have dragged the directory out from "My networks", or what ever it's called in english (on the start menu over the control panel). Now, when I try to visit the shared direcory I only get:

Index of /

--------------------------------------------------------------------------------
Name Size Date MIME Type
Desktop.ini 0.07 KB May 25, 2006 23:25:24 application/octet-stream
target.lnk 0.43 KB May 26, 2006 17:16:10 application/octet-stream


I do not see the files and directories that's in the web page folder. What's wrong? Everything else seems to work. I have win XP.

Is there a solution to my problem. I want to be able to change the files from any computer on the network and be able to see my changes on the server (abyss).
Back to top View user's profile Send private message
AbyssUnderground
-


Joined: 31 Dec 2004
Posts: 3855

PostPosted: Fri May 26, 2006 4:32 pm    Post subject: Reply with quote

Simple answer: Dragging and dropping it only created a shortcut. You need to physically select all the files/folders, and click copy and paste.

Is there a solution to my problem. I want to be able to change the files from any computer on the network and be able to see my changes on the server (abyss).

I do this on my own network. All you need to do is on the pc with Abyss on it, create a network share and then make a shortcut to that share on each PC you want to edit the files on.
_________________
Andy (AbyssUnderground) (previously The Inquisitor)
www.abyssunderground.co.uk
Back to top View user's profile Send private message Visit poster's website
Deasign
-


Joined: 18 Nov 2004
Posts: 4

PostPosted: Fri May 26, 2006 5:05 pm    Post subject: Reply with quote

hmm, strange...I get the same "message".

First I selected right clicked on my webpage folder on my stationary computer. I then selected to share the folder over the directory.

After that I started my laptop and selected:
Start -> My network(or whatever its called) -> Selected the folder called wepages and then copied it and then pasted it into D:. -> Then I selected the D:Webpage-folder on abyss and I get thhe message I've written over.

By the way, it seems like I can see the folder, but when I open it when pressing browse in Documents Path I can't see the rest of the folders and files.

Whats the problem? It seems like I'm doing something wrong in WIndows. Thank you for your fast and excellent support!
Back to top View user's profile Send private message
AbyssUnderground
-


Joined: 31 Dec 2004
Posts: 3855

PostPosted: Fri May 26, 2006 5:16 pm    Post subject: Reply with quote

You cannot copy and paste a network share directly. To do it you must open the network share then select the contents of the share (its folders and files) then copy and paste.

If you want to edit them so the changes appear on abyss simply edit the original in the network share directly. Make backups frequently if you do this to make sure you can restore pages if you make a mistake.
_________________
Andy (AbyssUnderground) (previously The Inquisitor)
www.abyssunderground.co.uk
Back to top View user's profile Send private message Visit poster's website
MonkeyNation
-


Joined: 05 Feb 2005
Posts: 921
Location: Cardiff

PostPosted: Fri May 26, 2006 5:40 pm    Post subject: Reply with quote

If I understand you correctly, you want the web server to serve a network resource?

The Inquisitor is correct, however you could avoid the whole copying and pasting problem by mounting the network share, and creating an alias to it in Abyss.
See: Right Click My Computer -> Map network drive.
_________________
Back to top View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger ICQ Number
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> Classic ASP All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group