webfilebrowser upload works with apache, not with abyss..?

 
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions
View previous topic :: View next topic  
Author Message
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Fri Mar 10, 2006 3:56 pm    Post subject: webfilebrowser upload works with apache, not with abyss..? Reply with quote

Hi everybody,
It's me again...

Still I'm trying to get abyss to work with Debian the way it should, like it did on my windows-
machine. And I'm not quite there, yet.
Got this webfilebrowser running, except upload (download is cool). No matter
what I try, nothing works, not from outside the LAN, inside, or even on localhost.
First I thought this would have something to do with setting the right permissions..?
( abyss runs with the same permissions like apache and every related folder does)
When I work with lampp, everything works perfectly, download, upload, creating and deleting of folders..?

Both servers point to the same interpreter (php-5.1.2) and the same php.ini!
So this shouldn't be a php-issue...

I'm pretty much helpless here!

Thanks for any advice!
Mike
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sat Mar 11, 2006 2:29 pm    Post subject: Re: webfilebrowser upload works with apache, not with abyss. Reply with quote

strinxx,

Is there an error message from PHP regarding the upload? If no, try changing the error parameters in php.ini to have it display the errors and let you know why the upload fails.

Abyss and Apache do not do anything to the uploaded file. It is PHP which handles it, so your problem is here with PHP which is probably unable to store the file in the temporary upload directory (mostly because of wrong file permissions).

You have also said that Abyss and Apache are using the same user account. What is the user running Abyss? How are you launching it (from the root account/what is the operating system user account configured in Abyss Web Server)?
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Mon Mar 13, 2006 4:10 pm    Post subject: Reply with quote

Thank you so much for your reply!
Unfortunately I don't get any error - though I have set the php.ini to show all errors.

I tried several possibilities to get the upload running: abyss as normal user, and
abyss as root. Right now it's running as root and everybody has every right to do anything with it - 777! (not really good, I know!)
The same with index.php (webfilebroser) and php-5.1.1.
Abyss starts on bootup from runlevel 5, process-id 40 - could this be the problem?

I have to start Apache manually, it runs as "nobody".
I tried this with abyss - without success.

Mike
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Tue Mar 14, 2006 10:58 am    Post subject: Reply with quote

strinxx,

We suggest creating a file phpinfo.php:

Code:
<?php
   phpinfo();
?>


Browse it and check the parameters of the PHP version Abyss is running. Check also the path of php.ini that is displayed. Is this the actual path of your php.ini file? Are the PHP parameters (regarding errors and the upload directory) fine?

The problem you are reporting here suggests that the PHP interpreter running under Abyss Web Server is not reading php.ini correctly.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Tue Mar 14, 2006 1:45 pm    Post subject: Reply with quote

Ok.
I createdthis file already and it actually works fine. Also webfilebrowser works.
Selecting and downloading of files is fine. So it works correctly, up to that point
when it comes to creating folders, or writing files. That's why I first thought this
should have something to do with setting permissions (Linux is new land here).

I checked it 1000 of times, the paths for the php.ini, php-5.1.1 are correct and point to the right directories. (which actually are the directories to apache, that comes
with kanotix). I also tried php-4.4.1... same matter.

Same results, when I tell abyss to serve form the apache-directory.
Everything works fine, except writing within a directory.

Mike
Back to top View user's profile Send private message
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Tue Mar 14, 2006 4:45 pm    Post subject: Reply with quote

Sorry guys!

I was completely wrong!!!
This php-info doesn't work at all! The only thing I get, is the question if I would like to download this
thing...?

Webfilebroser works...with the wellknown exceptions...
In all honesty, I have no idea anymore. Checked every path again and again.
As far as I was able to...

Help!
Back to top View user's profile Send private message
Marty_
-


Joined: 21 Feb 2006
Posts: 55

PostPosted: Tue Mar 14, 2006 5:10 pm    Post subject: Reply with quote

Excuse me if iam way off on this.......

Your trying to upload files into a directory correct ?

Well shouldnt that directory be a URL ie: not localhost/something/something

It should be your sites http://URL.com name or IP /something/something

Dont confuses the real c:/paths/ with the internet http://site.com/paths/

localhost is not part of your sites directory structure, your sites directory starts from where ever you set it to in abyss, so any paths should be set after that, also with no / at the start. The Abyss server already knows the c:/ bit/path you with me ?


Of course there are exceptions to the rule, but only if specifyed in the setup of whatever script you might be running.
Back to top View user's profile Send private message
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Tue Mar 14, 2006 9:42 pm    Post subject: Reply with quote

Thanx Marty, for helping me!

Well, I guess you're right!
I tried to upload from outside my LAN. And it looked good... until I found out that there was
nothing on my server!
So I tried whatever I knew, searched the web, of course... couldn't find the answer, til now.
Then I remembered apache, which comes with my Linux-Distribution (Kanotix) and everything
worked just fine, form inside the LAN, or outside...and on localhost!
If this beast only wasn't so hard to handle (at least for me...).
That's why I was so pleased with Abyss.
It worked just perfectly on my windows-machine.

Thanks again!
Mike
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Tue Mar 14, 2006 11:40 pm    Post subject: Reply with quote

strinxx,

Can you put the phpinfo.php file in the same directory as Web File Browser and try to test it again?

We cannot determine easily from your messages if the problem is related to PHP, to its configuration, to the script, to file permissions or to the user accounts you are using. So unless we go step by step and make the search space smaller, we cannot help you solving this issue.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Thu Mar 16, 2006 10:37 am    Post subject: Reply with quote

Yes, I know that!
And I really thank you guys for your patience!
I did put the php-info in the same directory. I then called it "index.php"
Cause that's what my html-page is pointing to.
Well....it didn't do anything.
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Thu Mar 16, 2006 10:50 am    Post subject: Reply with quote

strinxx,

So PHP is not working too? When you browse this index.php file containing a call to phpinfo(), "didn't do anything" means you get a blank page, an error, ...??
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Thu Mar 16, 2006 4:45 pm    Post subject: Reply with quote

Well,
it gives me the choice to download it...
not quite what we wanted...?
Today, I read an article about this "php-behaviour" and they said this might come from not adressing it the right way.
They said one should browse it by starting "http..." and so on.
I just referrenced it from the index.html.
So I'll try it on more time and get back to you.
Mike
Back to top View user's profile Send private message
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Thu Mar 16, 2006 5:48 pm    Post subject: Reply with quote

Ok,
this is (was) the situation:
I installed Abyss as root on a new Debian-installation.
Changed the owner and group of abyss to a normal user account.
This is now the same account, abyss runs after startup.
This user is the owner of the directories abyss has access to.
So he has write-permissions for these directories.
He also owns the webfilebrowser and the php-info-file.

When I rename the php-info to "index.php" - what I did with the wfb - then I get "error 500" now...?
When I run wfb as index.php, everything seems to be ok, it shows up correctly - but still not quite working!

When I try all this in apache's dirrectory, the php-info comes correctly too, with all the information.
Webfilebrowser works fine, without any faults.

I defenetely do believe this hasn't something to do with Abyss itself, this baby is great!
But nevertheless, I need the possibility to do a http-upload.

Could this be because the php-5.1.1 is kind of bound to apache, since it came with it?
Would I have to install it freshly?
What would be the best workaround for abyss to be installed?

I am new to linux, learned most of the things the hard way, over the last 2 weeks...
and unfortunately, regarding abyss and linux, I don't get much information on the forum.
Everything on the internet is related to linux with apache...

Do you have any suggestions where to get the right informations about installing abyss on linux
and about getting it running with php.
I mean, I followed everything I could find here, did whatever I was told to...still not working.
Maybe I missed something during the installation-process...?

I have no idea...

Thank you guys!
Mike
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Fri Mar 17, 2006 8:57 pm    Post subject: Reply with quote

strinxx,

Have you installed PHP support correctly?

If so, please go to the directory where the php file is and execute the following commad:

Code:
chmod -x *.php


Does it work now?
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Sun Mar 19, 2006 3:34 pm    Post subject: Reply with quote

As far as I know... I did!
index.php (webfilebroser) is set executable...
I actually set any related php-file executable, just to be sure.
In fstab, I added "exec" to the related partition's entry...
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Mon Mar 20, 2006 2:06 pm    Post subject: Reply with quote

strinxx wrote:
As far as I know... I did!
index.php (webfilebroser) is set executable...

.php files should not be set "executable". That's why we asked you to execute the command chmod -x *.php. It was to remove the executable bit from your .php files.

If a file is executable (chmod +x), Abyss Web Server won't seek for an interpreter to execute it (by searching the interpreters table). It will instead will directly ask the operating system to run it. And since .php files are not executable files, they fail and Abyss reports error 500.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Mon Mar 20, 2006 8:54 pm    Post subject: Reply with quote

Yeah...I get the point...
there is so much to learn out there and I'm really a beginner here with linux, abyss, php-stuff...

But...nevertheless... getting more and more deeper into lampp, I was able to set per-directory-acess
for some users, , set the document-root to the same folder like I set in Abyss, same index.php and so
on...and it just works!

Maybe my settings/ php-declarations aren't that wrong..?

Ok, I did chmod -x on the index.php and it gave me now the possibility to download it again...
or open it.

Any ideas?
Thanks for your help!
Back to top View user's profile Send private message
admin
Site Admin


Joined: 03 Mar 2002
Posts: 970

PostPosted: Tue Mar 21, 2006 12:56 am    Post subject: Reply with quote

strinxx,

If it offers it for download, that's because PHP declaration in Abyss Web Server is missing or wrong.

Could you please send us your abyss.conf file for review? Could you also include the full output of the execution of this command in the directory where index.php is:

Code:
pwd; ls -al


Please send the file and the output to support@aprelium.com and do not forget to add a reference to this forum post.
_________________
Follow @abyssws on Twitter
Subscribe to our newsletter
_________________
Forum Administrator
Aprelium - https://aprelium.com
Back to top View user's profile Send private message
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Wed Mar 22, 2006 5:44 pm    Post subject: Reply with quote

Ok, thank's a lot!
Everything is on the way!
Back to top View user's profile Send private message
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Thu Mar 30, 2006 12:58 pm    Post subject: Reply with quote

Hey guys...

I sent you everything as I was told to...weeks ago now.
Can I still wait for an answer ...?

In silent desperation and never ending hope
Mike
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Fri Mar 31, 2006 11:02 am    Post subject: Reply with quote

strinxx,

We apologize for the delay.

Your abyss.conf file and the ls results are fine.

Could you please go to the directory where index.php is located and execute:

Code:
/opt/lampp/bin/php-5.1.1 index.php


What are the results you get?
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Fri Apr 07, 2006 9:22 pm    Post subject: Reply with quote

Now I have to apologize for my abstinence...so sorry!

Ok.... it seems like it runs the wfb.
When I check the print, I'm able to recognize some of the wfb's entries.

Is this a good sign..?
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sat Apr 08, 2006 3:53 pm    Post subject: Reply with quote

strinxx,

Could you please create the phpinfo.php file and do the same with it (run it using the command line). Please send us the full output which is in the file output.txt.

Code:
/opt/lampp/bin/php-5.1.1 phpinfo.php > output.txt

_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Tue Apr 11, 2006 5:37 pm    Post subject: Reply with quote

Ok, you've already got it.

mike
Back to top View user's profile Send private message
strinxx
-


Joined: 27 Feb 2006
Posts: 20

PostPosted: Sun Apr 23, 2006 6:19 pm    Post subject: Reply with quote

Thanks soooo much you guys!

That did it!
Just installed the php5-cgi and it works perfect now!

Thank you thank you thank you!!!
Mike
Back to top View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group