Help using Abyss on Ubuntu linux *used Abyss on WinXP*

 
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions
View previous topic :: View next topic  
Author Message
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Sat Aug 12, 2006 1:55 am    Post subject: Help using Abyss on Ubuntu linux *used Abyss on WinXP* Reply with quote

This is what I get

firestarter@firestarter-laptop:~/abyssws$ sudo ./abyssws
Password:
Abyss Web Server X1 (v 2.3.2)
Copyright (C) Aprelium Technologies - 2001-2006


firestarter@firestarter-laptop:~/abyssws$

no ports or console address is listed... can someone please help me?
Back to top View user's profile Send private message
bprsk8r4272
-


Joined: 07 Mar 2006
Posts: 124
Location: Rochester, NY

PostPosted: Sat Aug 12, 2006 4:44 am    Post subject: Reply with quote

http://www.aprelium.com/data/doc/2/abyssws-linux-doc-html/install.html did you follow those instructions?
_________________
Back to top View user's profile Send private message Send e-mail Visit poster's website AIM Address MSN Messenger
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Sat Aug 12, 2006 6:05 am    Post subject: Reply with quote

Just to verify..... I run this..

sudo tar xzfm <abyssdownload>

no errors.. then..
cd /abyssws
then
sudo ./abyssws
it goes

firestarter@firestarter-laptop:~/abyssws$ sudo ./abyssws
Abyss Web Server X1 (v 2.3.2)
Copyright (C) Aprelium Technologies - 2001-2006


firestarter@firestarter-laptop:~/abyssws$

no IP or port number... and there isn't a process running.
So yes, I beleive I did what the guide says.
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sat Aug 12, 2006 7:59 pm    Post subject: Reply with quote

pyromaniak,

Try installing and running Abyss Web Server using a normal user account for the first time. Running it as root will make things more complex because of Unix' permission system which is different from Windows.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Sun Aug 13, 2006 12:01 am    Post subject: Reply with quote

firestarter@firestarter-laptop:~$ tar xzfm abwsx1.tgz
firestarter@firestarter-laptop:~$ cd abyssws
firestarter@firestarter-laptop:~/abyssws$ ./abyssws
Abyss Web Server X1 (v 2.3.2)
Copyright (C) Aprelium Technologies - 2001-2006


firestarter@firestarter-laptop:~/abyssws$

Thats all there is.... any ideas?
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sun Aug 13, 2006 3:24 pm    Post subject: Reply with quote

pyromaniak,

What is the result of the execution of
Code:
ls -al
in the abyssws directory?
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
roganty
-


Joined: 08 Jun 2004
Posts: 357
Location: Bristol, UK

PostPosted: Sun Aug 13, 2006 5:05 pm    Post subject: Reply with quote

pyromaniak wrote:
firestarter@firestarter-laptop:~$ tar xzfm abwsx1.tgz
firestarter@firestarter-laptop:~$ cd abyssws
firestarter@firestarter-laptop:~/abyssws$ ./abyssws
Abyss Web Server X1 (v 2.3.2)
Copyright (C) Aprelium Technologies - 2001-2006


firestarter@firestarter-laptop:~/abyssws$

Thats all there is.... any ideas?



pyromaniak, have you tried starting abyss with the -d switch?
eg
Quote:
$ cd /abyssws
/abyssws$ ./abyssws -d
[dramatic pause]
/abyssws$


That should lauch abyss as a daemon

have you also checked for any error reports in the abyssws/ directory or the abyssws/log/ folder?

have you tried running netstat as root to see if abyss is listening to a port?
Quote:
$ su
Password:
# netstat -p -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
[cut]
tcp 0 0 *:9999 *:* LISTEN 1902/abyssws
[cut]
tcp 0 0 *:http *:* LISTEN 1902/abyssws
[cut]

_________________
Anthony R

Roganty
| Links-Links.co.uk
Back to top View user's profile Send private message Visit poster's website
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Mon Aug 14, 2006 5:31 am    Post subject: Reply with quote

aprelium wrote:
pyromaniak,

What is the result of the execution of
Code:
ls -al
in the abyssws directory?


firestarter@firestarter-laptop:~/abyssws$ ls -al
total 484
drwxr-xr-x 7 firestarter firestarter 304 2006-08-12 16:00 .
drwxr-xr-x 48 firestarter firestarter 1976 2006-08-13 20:24 ..
-rw------- 1 firestarter firestarter 10938 2006-08-12 16:00 abyss.conf
-rwxr-xr-x 1 firestarter firestarter 459808 2006-08-12 15:59 abyssws
drwxr-xr-x 2 firestarter firestarter 1160 2006-08-12 15:59 console
drwxr-xr-x 2 firestarter firestarter 1576 2006-08-12 15:59 doc
drwxr-xr-x 2 firestarter firestarter 112 2006-08-12 15:59 htdocs
-rw-r--r-- 1 firestarter firestarter 582 2006-08-12 15:59 Installation Instructions.html
drwxr-xr-x 2 firestarter firestarter 96 2006-08-12 15:59 lang
-rw-r--r-- 1 firestarter firestarter 8326 2006-08-12 15:59 license.txt
drwxr-xr-x 2 firestarter firestarter 48 2006-08-12 15:59 log
firestarter@firestarter-laptop:~/abyssws$
Back to top View user's profile Send private message
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Mon Aug 14, 2006 5:39 am    Post subject: Reply with quote

Running with ./abyssws -d just blink for a split second, and I was back at the command line..

This is the netstat you asked me to run (which was done directly after running it like a daemon

firestarter@firestarter-laptop:~/abyssws$ sudo netstat -p -l
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:51234 *:* LISTEN 5 007/server_linux
tcp 0 0 *:14534 *:* LISTEN 5 007/server_linux
tcp 0 0 localhost:ipp *:* LISTEN 4 433/cupsd
udp 0 0 *:8767 *:* 5 007/server_linux
udp 0 0 *:bootpc *:* 3 595/dhclient3
udp 0 0 *:bootpc *:* 4 976/dhclient3
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node PID/Program name Pat h
unix 2 [ ACC ] STREAM LISTENING 19991 7568/notification-d / tmp/orbit-firestarter/linc-1d90-0-ff6d099598d5
unix 2 [ ACC ] STREAM LISTENING 9489 3937/acpid / var/run/acpid.socket
unix 2 [ ACC ] STREAM LISTENING 18241 7410/gnome-terminal / tmp/orbit-firestarter/linc-1cf2-0-10ef328a415a5
unix 2 [ ACC ] STREAM LISTENING 10690 4478/hald @ /tmp/hald-runner/dbus-WKv5H1hDXi
unix 2 [ ACC ] STREAM LISTENING 19426 7527/metacity / tmp/orbit-firestarter/linc-1d67-0-1f526ad443e06
unix 2 [ ACC ] STREAM LISTENING 12066 4910/update-notifie / tmp/orbit-firestarter/linc-132e-0-7fb69869ab81
unix 2 [ ACC ] STREAM LISTENING 15665 6044/bonobo-activat / tmp/orbit-root/linc-179c-0-34b65d72c86ae
unix 2 [ ACC ] STREAM LISTENING 15683 6046/gnome-vfs-daem / tmp/orbit-root/linc-179e-0-1bca7d76dce90
unix 2 [ ACC ] STREAM LISTENING 15706 6052/mapping-daemon / tmp/mapping-root
unix 2 [ ACC ] STREAM LISTENING 12105 4943/gnome-power-ma / tmp/orbit-firestarter/linc-1336-0-6dc14b697b39e
unix 2 [ ACC ] STREAM LISTENING 12131 4920/gnome-cups-ico / tmp/orbit-firestarter/linc-1338-0-6dc14b687b0
unix 2 [ ACC ] STREAM LISTENING 12160 4937/trashapplet / tmp/orbit-firestarter/linc-1349-0-53f003068cdc7
unix 2 [ ACC ] STREAM LISTENING 12183 4942/mapping-daemon / tmp/mapping-firestarter
unix 2 [ ACC ] STREAM LISTENING 10689 4478/hald @ /tmp/hald-local/dbus-eDiWpkvlJ4
unix 2 [ ACC ] STREAM LISTENING 10601 4433/cupsd / var/run/cups/cups.sock
unix 2 [ ACC ] STREAM LISTENING 10483 4385/gdm / tmp/.gdm_socket
unix 2 [ ACC ] STREAM LISTENING 10565 4402/X / tmp/.X11-unix/X0
unix 2 [ ACC ] STREAM LISTENING 11585 4869/ssh-agent / tmp/ssh-HDKnxu4827/agent.4827
unix 2 [ ACC ] STREAM LISTENING 11609 4875/gconfd-2 / tmp/orbit-firestarter/linc-130b-0-4f0e5b3e80a27
unix 2 [ ACC ] STREAM LISTENING 12711 5000/xchat-gnome / tmp/orbit-firestarter/linc-1388-0-628f1640be1d9
unix 2 [ ACC ] STREAM LISTENING 15641 6041/gconfd-2 / tmp/orbit-root/linc-1799-0-17cb63285d79d
unix 2 [ ACC ] STREAM LISTENING 11619 4827/x-session-mana / tmp/orbit-firestarter/linc-12db-0-67371408921ea
unix 2 [ ACC ] STREAM LISTENING 11837 4827/x-session-mana / tmp/.ICE-unix/4827
unix 2 [ ACC ] STREAM LISTENING 12371 4965/gnome-netstatu / tmp/orbit-firestarter/linc-1365-0-1cf17af086c5
unix 2 [ ACC ] STREAM LISTENING 11846 4878/gnome-keyring- / tmp/keyring-WTYEwD/socket
unix 2 [ ACC ] STREAM LISTENING 10646 4462/dbus-daemon / var/run/dbus/system_bus_socket
unix 2 [ ACC ] STREAM LISTENING 11858 4880/bonobo-activat / tmp/orbit-firestarter/linc-1310-0-208bb05f7335b
unix 2 [ ACC ] STREAM LISTENING 11882 4882/gnome-settings / tmp/orbit-firestarter/linc-1312-0-47ba4eecd1283
unix 2 [ ACC ] STREAM LISTENING 11890 4884/esd / tmp/.esd-1000/socket
unix 2 [ ACC ] STREAM LISTENING 12388 4969/multiload-appl / tmp/orbit-firestarter/linc-1369-0-1cf17af043854
unix 2 [ ACC ] STREAM LISTENING 11946 4895/gnome-panel / tmp/orbit-firestarter/linc-131f-0-4961db0a5951f
unix 2 [ ACC ] STREAM LISTENING 12444 4961/clock-applet / tmp/orbit-firestarter/linc-1361-0-13028bded81f
unix 2 [ ACC ] STREAM LISTENING 11973 4903/gnome-volume-m / tmp/orbit-firestarter/linc-1323-0-4961db0ab33fc
unix 2 [ ACC ] STREAM LISTENING 12010 4897/nautilus / tmp/orbit-firestarter/linc-1321-0-4961db0b3711b
unix 2 [ ACC ] STREAM LISTENING 12062 4913/gnome-vfs-daem / tmp/orbit-firestarter/linc-1331-0-1b69f955a37b
unix 2 [ ACC ] STREAM LISTENING 13343 5330/firefox-bin / tmp/orbit-firestarter/linc-14d2-0-26751d6be5d3f
unix 2 [ ACC ] STREAM LISTENING 15647 6039/nautilus / tmp/orbit-root/linc-1797-0-22a66f061ec2
unix 2 [ ACC ] STREAM LISTENING 12351 4967/cpufreq-applet / tmp/orbit-firestarter/linc-1367-0-2ffbcdc4e29cc
unix 2 [ ACC ] STREAM LISTENING 11590 4873/dbus-daemon @ /tmp/dbus-JkWW5Wfl3j
unix 2 [ ACC ] STREAM LISTENING 15113 5714/alltray / tmp/orbit-firestarter/linc-1652-0-332717fc9721b
unix 2 [ ACC ] STREAM LISTENING 12681 4989/gnome-screensa / tmp/orbit-firestarter/linc-137a-0-3d88dbbcd93c5
unix 2 [ ACC ] STREAM LISTENING 15604 6036/gksu / tmp/orbit-firestarter/linc-1794-0-5878017a83b32
unix 2 [ ACC ] STREAM LISTENING 12341 4963/mixer_applet2 / tmp/orbit-firestarter/linc-1363-0-2ffbcdc4da031
Back to top View user's profile Send private message
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Mon Aug 14, 2006 5:49 am    Post subject: Reply with quote

Also, nothing in the /log folder... no logs in the main folder...
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Mon Aug 14, 2006 8:59 am    Post subject: Reply with quote

pyromaniak,

That's very strange. Can you please let us know what is the result of execution of
Code:
uname -a

_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Mon Aug 14, 2006 9:01 am    Post subject: Reply with quote

Linux firestarter-laptop 2.6.15-26-686 #1 SMP PREEMPT Thu Aug 3 03:13:28 UTC 2006 i686 GNU/Linux
Back to top View user's profile Send private message
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Mon Aug 14, 2006 9:07 am    Post subject: Reply with quote

Had someone SSH into my machine and

<sethk> well, I found the problem, but I'm not sure how to fix it
<PyroManiak> oh?
<sethk> there is a lang subdirectory
<sethk> it opens the directory file, then tries to retriev the listing
<sethk> here, where it works, that goes normally(his machine)
<sethk> there, the process terminates abnormally(my machine)

he also mentioned something about reiserfs file system might be doing it...

Unless I get another solution, he's going to help me test the webserver on a ext3 partition..
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Tue Aug 15, 2006 2:22 pm    Post subject: Reply with quote

pyromaniak,

Could you please try an old version of X1 from http://www.aprelium.com/downloads/old.html and let us know if it shows the same behavior?
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Fri Aug 18, 2006 6:02 am    Post subject: Reply with quote

The version you requested I try works flawlessly as I can tell

So, does that give you any clue to the problem?
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Fri Aug 18, 2006 3:11 pm    Post subject: Reply with quote

pyromaniak wrote:
The version you requested I try works flawlessly as I can tell

So, does that give you any clue to the problem?


Thanks. This gives us a partial clue but we'd like to have more information about the latest version to help us fix it quickly.

Could you please install the latest version 2.3.2 in another directory and run abyssws using strace as follows:

Code:
strace -otrace.txt ./abyssws --slave


This will produce a very large file trace.txt which contains all the system calls issued by Abyss Web Server. --slave will prevent the server from running the anticrash protection which will help us follow a single process.

Please compress trace.txt (using the command bzip2 -9 trace.txt) and send it to support@aprelium.com with a reference to this forum thread.

Until we fix this bug, you can use version 2.0.6 which we believe will work trouble free: http://www.aprelium.com/data/abwsx1-206.tgz .
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Sat Aug 19, 2006 1:25 am    Post subject: Reply with quote

OK, version 2.0.6 runs just fine as well. (horay for the new interface again!).

Something I've just noted... the new version X1 2.3.2 is running fine now... but.. its in a subdirectory (created so I could install both)

2.0.6 is in home/user/abyssws <-- runs fine
2.3.2 is in home/user/abyssws <-- only works if I run ./abyssws --slave (dies after about 1 minute)

I'll submit the strace for it.
Back to top View user's profile Send private message
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Sat Aug 19, 2006 1:53 am    Post subject: Reply with quote

OK.... well, I'm not sure what is going on... but I deleted all the folders I had for abyssws and ran the installer again for version 2.3.2 and it seems to be running fine now..
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sat Aug 19, 2006 3:29 pm    Post subject: Reply with quote

pyromaniak,

That's really weird. Please let us know if you could reproduce the problem and generate the strace.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Sun Aug 20, 2006 1:12 pm    Post subject: Reply with quote

Yeah, its broken again... this is really weird...

When I run strace, I can access the website just fine... it doesn't seem to stop running the process but I'll let it go and see how long it lasts so I Can mail the strace file.

I think --slave is what is keeping it alive.
Back to top View user's profile Send private message
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Mon Aug 21, 2006 7:44 am    Post subject: Reply with quote

Btw... I emailed the strace information last night.
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Mon Aug 21, 2006 11:07 am    Post subject: Reply with quote

pyromaniak wrote:
Btw... I emailed the strace information last night.


Thanks.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Wed Aug 23, 2006 4:14 am    Post subject: Reply with quote

Will I get notification to what the problem is?
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Wed Aug 23, 2006 3:48 pm    Post subject: Reply with quote

pyromaniak wrote:
Will I get notification to what the problem is?


We're still working on it. Since we do not have your exact configuration (the OS distribution, etc...), we have to do a lot of guess work and validate every hypothesis we may have.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Tue Aug 29, 2006 5:58 am    Post subject: Reply with quote

Any updates this week? I can give you anything you want to know about my system if that would help.
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Wed Aug 30, 2006 9:12 pm    Post subject: Reply with quote

pyromaniak wrote:
Any updates this week? I can give you anything you want to know about my system if that would help.


We're probably going to install the version of Debian you have for better results. We guess we're going to need your help very soon :-)
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
canoedf
-


Joined: 25 Oct 2004
Posts: 13
Location: Colorado

PostPosted: Thu Aug 31, 2006 4:24 pm    Post subject: Reply with quote

I will be interested in the outcome of this too.

I want to be sure that my issue -[url] http://www.aprelium.com/forum/viewtopic.php?t=9313[/url] - is not part of this.
_________________
Dan
Back to top View user's profile Send private message
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Fri Sep 01, 2006 5:27 am    Post subject: Reply with quote

Ubuntu 6.06 patched to current on i686 kernel.
1ghz p3
384mb pc133
2x 40gb 5400rpm ATA

I am also willing to provide remote SSH access or anything that might be able to help trouble shoot. I've gotten very curious of the problem now and this machine is basically just here as a webserver and internet browser. If this is wanted, let me know and I can email directly with information to help out.
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Fri Sep 01, 2006 3:38 pm    Post subject: Reply with quote

pyromaniak wrote:
I am also willing to provide remote SSH access or anything that might be able to help trouble shoot. I've gotten very curious of the problem now and this machine is basically just here as a webserver and internet browser. If this is wanted, let me know and I can email directly with information to help out.


SSH access will help us a lot. Thanks.

Could you please create us a user account on your computer and send us the credentials to support@aprelium.com (with a reference to this forum thread)? We'll let you know when we will connect to the server 24 hours in advance at least.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
Mikor
-


Joined: 21 Aug 2006
Posts: 144
Location: Hull, England

PostPosted: Fri Sep 01, 2006 7:37 pm    Post subject: Reply with quote

Have you found out what the problem is yet? I'm trying to set up abyss on my brothers ubuntu desktop, but when I try to run it as root:

Code:
root@ubuntu-mason:~/programs/abyssws# ./abyssws
Abyss Web Server X1 (v 2.3.2)
Copyright (C) Aprelium Technologies - 2001-2006


Critical: Cannot execute the server using root privileges (key: root/server/parameters/opsys/sysuser - file: /home/mason/programs/abyssws/abyss.conf - line: 0 - col: 0)


I'll try to run as a normal user and tell you if it works or not.

EDIT: Here is the result of running ./abyssws as a normal user:

Code:
mason@ubuntu-mason:~$ cd ~/programs/abyssws
mason@ubuntu-mason:~/programs/abyssws$ ./abyssws
Abyss Web Server X1 (v 2.3.2)
Copyright (C) Aprelium Technologies - 2001-2006


Error: No such file or directory (key: /root/console/bindip - file: /home/mason/programs/abyssws/abyss.conf - line: 0 - col: 0)
Error: Cannot save the configuration file (key: /root/console/bindip - file: /home/mason/programs/abyssws/abyss.conf - line: 0 - col: 0)
Critical: No such file or directory

_________________
Yarrt.com - Free Arcade
RypNet.co.uk - Online Game

MSN:
michael_walker_2004 <at> hotmail <dot> com
Back to top View user's profile Send private message Send e-mail MSN Messenger
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sun Sep 03, 2006 3:08 pm    Post subject: Reply with quote

Mikor,

Your problem and the problem reported above are different. You are trying to run Abyss Web Server from your root account which is not allowed by default (you can force Abyss Web Server to do it by adding -r to the command line).

You are also having a file access permission because the user that is trying to run Abyss Web Server in the second test has not the right to access the files which were created by root. Install Abyss Web Server using a normal user account (and not a root account). Then you can start it from your root account to access ports < 1024.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
Mikor
-


Joined: 21 Aug 2006
Posts: 144
Location: Hull, England

PostPosted: Sun Sep 03, 2006 4:34 pm    Post subject: Reply with quote

aprelium wrote:
Mikor,

Your problem and the problem reported above are different. You are trying to run Abyss Web Server from your root account which is not allowed by default (you can force Abyss Web Server to do it by adding -r to the command line).

You are also having a file access permission because the user that is trying to run Abyss Web Server in the second test has not the right to access the files which were created by root. Install Abyss Web Server using a normal user account (and not a root account). Then you can start it from your root account to access ports < 1024.


Thanks
_________________
Yarrt.com - Free Arcade
RypNet.co.uk - Online Game

MSN:
michael_walker_2004 <at> hotmail <dot> com
Back to top View user's profile Send private message Send e-mail MSN Messenger
pyromaniak
-


Joined: 12 Aug 2006
Posts: 17

PostPosted: Tue Sep 12, 2006 2:36 am    Post subject: Reply with quote

Have you guys recieved my email with the connection information?
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Wed Sep 13, 2006 12:52 pm    Post subject: Reply with quote

pyromaniak wrote:
Have you guys recieved my email with the connection information?


Yes. Thank you for sending it to us. We're going to work on this bug by the end of this week.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3720
Location: USA, GA

PostPosted: Wed Oct 25, 2006 11:50 pm    Post subject: Reply with quote

Sorry to bring this topic back up. I wanted to just say that Ubuntu Linux works
fine. I think he/she simply forgot to type in the password.

Example.

01. Untar and put abyssws folder in /home/user
02. Open a terminal and type the following

Command: cd /home/user/abyssws
sudo ./abyssws
Password: (Your User Account Password)

Note: Change "user" with your account username in the path. This works
fine on my system. I have a Virtual Machine running Ubuntu Linux. I don't
think the -r or -allow-root arguments work.
_________________
Computer Programmer & Networking Specialist

Back to top View user's profile Send private message Visit poster's website MSN Messenger
dave64
-


Joined: 04 Feb 2007
Posts: 2

PostPosted: Sun Feb 04, 2007 5:12 pm    Post subject: problems with abyss on mandrivva Reply with quote

been reading these post with interest as i have the same problem running on my mandriva 7 system, i can run older versions of abyss ok but this new version just drops me to the command line with no errors reported. anyone got any idea what it could be??
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sun Feb 04, 2007 9:51 pm    Post subject: Re: problems with abyss on mandrivva Reply with quote

dave64,

Is the user who is running abyssws the same one who has installed Abyss Web Server? Have you followed the suggested installation instructions provided above?
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
dave64
-


Joined: 04 Feb 2007
Posts: 2

PostPosted: Mon Feb 05, 2007 6:33 pm    Post subject: Reply with quote

Quote:
Is the user who is running abyssws the same one who has installed Abyss Web Server? Have you followed the suggested installation instructions provided above?

i installed abyss on my user account, if i use older versions all ok, this new version will not run.
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Wed Feb 07, 2007 11:40 pm    Post subject: Reply with quote

dave64,

We'll be working on that problem and hopefully a version which solves it will be available soon.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group