Perl Path "The system cannot find the path specified&qu

 
Post new topic   Reply to topic    Aprelium Forum Index -> FastCGI/CGI
View previous topic :: View next topic  
Author Message
ntloc
-


Joined: 26 Feb 2004
Posts: 35
Location: UT

PostPosted: Sat Feb 28, 2004 9:19 pm    Post subject: Perl Path "The system cannot find the path specified&qu Reply with quote

Hi, I install Perl and everything else like the instruction told me to do. I run the cgi script and everything is working fine accept when I open the cgi error log file out, it wrote in there: "The system cannot find the path specified." everytime I run any kind of cgi script (still working on the outside but it reports to cgi log error). My scripts are still working perfectly fine but is there anyway that I can fix the path or something to make that error go away.

This is my perl path I installed on my server:

C:/usr/bin/perl.exe

NOTE: I make the Dir Perl become usr so it can match the path in most cgi scripts.

Thank you!
Back to top View user's profile Send private message Visit poster's website
iNaNimAtE
-


Joined: 05 Nov 2003
Posts: 2381
Location: Everywhere you're not.

PostPosted: Sat Feb 28, 2004 11:24 pm    Post subject: Reply with quote

When running Perl scripts, Abyss by default does not find the Perl interpreter by the script's #! line. You should try setting it to #!/Perl and in the Abyss console, make sure it is set to NOT resolve the interpreter from that line.
_________________
Bienvenidos!
Back to top View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
ntloc
-


Joined: 26 Feb 2004
Posts: 35
Location: UT

PostPosted: Sun Feb 29, 2004 1:56 am    Post subject: Still giving the error! Reply with quote

Yes, I set both:

Resolve interpreter using the script's #! line
Resolve interpreter using the Windows Registry

I set both of these to lines to NO in the Abyss Console but it still giving that error.
Back to top View user's profile Send private message Visit poster's website
Axis
-


Joined: 29 Sep 2003
Posts: 336

PostPosted: Sun Feb 29, 2004 5:31 am    Post subject: Reply with quote

Hi ntloc--

You should try setting "Resolve interpreter using the script's #! line" to "yes" while leaving the "Resolve interpreter using the Windows Registry" set to "no" and then making sure you have your correct path to the CGI Interpreter.

This from the help files in the console:
"Resolve CGI Interpreter using the #! Line in Script:
Read the first line of the CGI script. If it begins with #!, the rest of the line is considered as the path to the script's interpreter."

Regards,
Axis
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sun Feb 29, 2004 4:03 pm    Post subject: Re: Perl Path "The system cannot find the path specifie Reply with quote

ntloc,

To make you life easier, set "Resolve the interpreter using #! line" to No in Abyss and set the CGI Parameters of Perl as described in http://www.aprelium.com/abyssws/perl.html . Abyss will reply on the file extension ONLY to know what Interpreter it will use (and will ignore the #! lines so you can leave them unmodified).
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
ntloc
-


Joined: 26 Feb 2004
Posts: 35
Location: UT

PostPosted: Mon Mar 01, 2004 12:48 am    Post subject: continue... Reply with quote

Still giving that errors but i guess it's ok because all the scripts are wokring fine on the outside. It gave me the errors in the cgi error log but the scripts is working so... But thanks anyway, maybe this is just a bug and I hope your next version is going fix it. Like your server software alot.

Thanks again.
LN
Back to top View user's profile Send private message Visit poster's website
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3718
Location: USA, GA

PostPosted: Mon Mar 01, 2004 3:48 am    Post subject: Reply with quote

If anything its a bug with the
script , post a copy and i will
test it out for you!
_________________
Computer Programmer & Networking Specialist

Back to top View user's profile Send private message Visit poster's website MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> FastCGI/CGI All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group