php.ini file configuration file not loading PATH not correct

 
Post new topic   Reply to topic    Aprelium Forum Index -> PHP
View previous topic :: View next topic  
Author Message
mtdew3q
-


Joined: 16 Oct 2005
Posts: 19

PostPosted: Sat May 28, 2022 2:00 am    Post subject: php.ini file configuration file not loading PATH not correct Reply with quote

Hi all-

The path in my phpinfo() in mozilla firefox is giving the wrong directory. It displays phpinfo.

Configuration File (php.ini) Path /home/user/php-7.4.29/lib
Loaded Configuration File

I tried to put a switch to have it load the right php.ini file

FastCGI (Local - Pipes) /home/user/php-7.4.29/bin/php-cgi -c /home/user/php-7.4.29/

is there a cool trick besides this to get abyss and PhP to load the right php.ini? I'd like to somehow set it please.
thanks for any tips- roboloki
Back to top View user's profile Send private message
mtdew3q
-


Joined: 16 Oct 2005
Posts: 19

PostPosted: Sun May 29, 2022 4:28 am    Post subject: re: Load configuration file fixed php.ini SOLVED Reply with quote

HI all-

good news... I have amf3_php extension loading now so I can fool with apache roayle.
Now on to getting the mxml and actionscript fired up.

Some things I did wrong were:

I needed to put in the arguments section for the cgi-interpreter the following -
-c /PATH/TO/PHPINI -m

This loads the right php.ini file and then loads the modules.

There is an environment variable that you can use to set php.ini location. Its name is PHPRC. I will set that in my .bashrc. Don't forget to $source .bashrc.

That is the strory of how I loaded an extension from php_amf3.

thanks,
roboloki
Back to top View user's profile Send private message
admin
Site Admin


Joined: 03 Mar 2002
Posts: 1239

PostPosted: Mon May 30, 2022 10:01 pm    Post subject: Re: re: Load configuration file fixed php.ini SOLVED Reply with quote

mtdew3q,

Thank you for sharing the solution with us.
_________________
Follow @abyssws on Twitter
Subscribe to our newsletter
_________________
Forum Administrator
Aprelium - https://aprelium.com
Back to top View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 940
Location: Michigan, USA

PostPosted: Wed Jun 08, 2022 2:02 pm    Post subject: Re: php.ini file configuration file not loading PATH not cor Reply with quote

mtdew3q wrote:
FastCGI (Local - Pipes) /home/user/php-7.4.29/bin/php-cgi -c /home/user/php-7.4.29/

is there a cool trick besides this to get abyss and PhP to load the right php.ini? I'd like to somehow set it please.
thanks for any tips- roboloki


Setting the argument as you've done is the right way to use a different php.ini file. It sounds like you're running Linux? If so, your package manager has a default php.ini location. In Debian using apt, my default location is something like /etc/php/7.4/cgi/php.ini. (If you've built PHP from source, the default location was probably an option you overlooked in the build process somewhere. I've never built PHP from source though, so I can't confirm that.)
_________________
Stephen
Need a LitlURL?


http://CodeBin.yi.org
Back to top View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> PHP All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group