PHP 5.1.4

 
Post new topic   Reply to topic    Aprelium Forum Index -> PHP
View previous topic :: View next topic  
Author Message
Yami King
-


Joined: 08 Sep 2005
Posts: 120

PostPosted: Fri May 05, 2006 5:16 pm    Post subject: PHP 5.1.4 Reply with quote

Code:
My settings:
> php-cgi.exe as PHP-Style and FastCGI interpreter;
> .php, .php3, .php4, .php5, .phtml as file extension;
> almost every php extension;


Hi,

Today I downloaded PHP 5.1.4 (zip) and copied all the files from the zipfile to overwrite my current php files as I always do.

But.. This time php first gave me a warning: hash already loaded. That was an easy one to handle :P, I just set the extension handler as a comment in the php.ini file. Although that bug was 'fixed'/avoided, another one showed up: 503 - Service unavailable.

How is this possible? Is it because PHP completely renewed their FastCGI settings, or what?
Back to top View user's profile Send private message Send e-mail
AbyssUnderground
-


Joined: 31 Dec 2004
Posts: 3855

PostPosted: Fri May 05, 2006 5:23 pm    Post subject: Reply with quote

Yes this is probably caused by FastCGI if it is the newest version so switch to normal CGI until aprelium resolve it in Abyss.
_________________
Andy (AbyssUnderground) (previously The Inquisitor)
www.abyssunderground.co.uk
Back to top View user's profile Send private message Visit poster's website
Yami King
-


Joined: 08 Sep 2005
Posts: 120

PostPosted: Fri May 05, 2006 5:29 pm    Post subject: Reply with quote

Changed FastCGI to CGI/ISAPI.
Didn't work > Internal Server Error > php-cgi.exe cannot be executed immediatly, or something like this.

Changed php-cgi.exe to php.exe.
Didn't work > Broken pipe


What's going on? :S
Back to top View user's profile Send private message Send e-mail
AbyssUnderground
-


Joined: 31 Dec 2004
Posts: 3855

PostPosted: Fri May 05, 2006 5:33 pm    Post subject: Reply with quote

Your script might have an error. Try a simple phpinfo(); script.

Code:
<?php
phpinfo();
?>

_________________
Andy (AbyssUnderground) (previously The Inquisitor)
www.abyssunderground.co.uk
Back to top View user's profile Send private message Visit poster's website
MonkeyNation
-


Joined: 05 Feb 2005
Posts: 921
Location: Cardiff

PostPosted: Fri May 05, 2006 5:40 pm    Post subject: Reply with quote

Kill any PHP processes still remaining from before you changed from FastCGI.
_________________
Back to top View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger ICQ Number
Yami King
-


Joined: 08 Sep 2005
Posts: 120

PostPosted: Fri May 05, 2006 5:54 pm    Post subject: Reply with quote

@Inquisitor: Still same result: Broken pipe

@MonkeyNation: Already did this, unfortunatly didn't had any success in this either :(.
Back to top View user's profile Send private message Send e-mail
dave-t
-


Joined: 25 Feb 2006
Posts: 3

PostPosted: Sat May 06, 2006 12:46 am    Post subject: Reply with quote

I have the same problem - No matter what combination I use I cannot get Abyss to work with PHP V 5.1.4

Anyone got a fix?
Back to top View user's profile Send private message
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3719
Location: USA, GA

PostPosted: Sat May 06, 2006 3:07 am    Post subject: Reply with quote

That's odd,

I'm able to run PHP v5.1.4 just fine without FastCGI enabled. Are you sure
you followed the instructions the correct way?

Interface: CGI/ISAPI
Interpreter: C:\PHP\php-cgi.exe
Type: PHP Style
Associated Extensions: php

Those settings work fine for me when installing PHP v5.1.4. Maybe you should
try going over your installation and trying again. The only thing that won't work
right now, is PHP in FastCGI up to that new version because of the new FastCGI
interface PHP developers wrote. Aprelium is working on a fix.

Sincerely, TRUSTAbyss
_________________
Computer Programmer & Networking Specialist

Back to top View user's profile Send private message Visit poster's website MSN Messenger
dave-t
-


Joined: 25 Feb 2006
Posts: 3

PostPosted: Sat May 06, 2006 9:52 am    Post subject: Reply with quote

Hi

I have done a complete re-install of PHP, and re-configured the PHP settings this morning with the server stopped, re-booted and stated the server

I now get the following error

PHP Warning: PHP Startup: Unable to load dynamic library './php_mysql.dll' - The specified module could not be found.
in Unknown on line 0
PHP Fatal error: Call to undefined function mysql_connect() in C:\Websites\coolv35\hamlib\HW\DBAccess\HWmysql.php on line 74

So I am beginning to think this is a script error ???
Back to top View user's profile Send private message
AbyssUnderground
-


Joined: 31 Dec 2004
Posts: 3855

PostPosted: Sat May 06, 2006 10:02 am    Post subject: Reply with quote

A simple search would have found the answer. Please search first before posting in future.

http://www.abyssunderground.co.uk/awsfaq.php?page=cannot_load_mysql_extension
_________________
Andy (AbyssUnderground) (previously The Inquisitor)
www.abyssunderground.co.uk
Back to top View user's profile Send private message Visit poster's website
dave-t
-


Joined: 25 Feb 2006
Posts: 3

PostPosted: Sat May 06, 2006 10:12 am    Post subject: Reply with quote

The Inquisitor wrote:
A simple search would have found the answer. Please search first before posting in future.

http://www.abyssunderground.co.uk/awsfaq.php?page=cannot_load_mysql_extension


Acknowledged - I apologise.

Now fixed

Thanks
Back to top View user's profile Send private message
Yami King
-


Joined: 08 Sep 2005
Posts: 120

PostPosted: Sat May 06, 2006 11:57 am    Post subject: Reply with quote

Reinstalled PHP 5.1.2, this one works great I'll wait installing php5.1.3 & php5.1.4
Back to top View user's profile Send private message Send e-mail
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sat May 06, 2006 2:05 pm    Post subject: Reply with quote

The Inquisitor wrote:
Yes this is probably caused by FastCGI if it is the newest version so switch to normal CGI until aprelium resolve it in Abyss.

The problem is not in Abyss Web Server. The problem is that they've broken the FastCGI support when they rewrote it. And 5.1.4 has been released to fix some obvious FastCGI bugs in 5.1.3 but a lot of problems are still there.

As we have said, we are not going to wait for them to restore the features they've broken. So we'll update Abyss in order to support their new buggy version.

Until them, use 5.1.2 (works fine with FastCGI and Abyss) or use CGI.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
devastator82
-


Joined: 10 Mar 2006
Posts: 25
Location: Lithuania

PostPosted: Mon May 15, 2006 4:59 am    Post subject: Reply with quote

this is not a php error or bug.
Newest abyss server not working fine on the win2003 OS.
egzample: forum SMF not working, phpmyadmin too :)
On winXP these scripts working fine, in the win2003 with same php and firewall settings not....
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Mon May 15, 2006 9:51 am    Post subject: Reply with quote

devastator82 wrote:
this is not a php error or bug.
Newest abyss server not working fine on the win2003 OS.
egzample: forum SMF not working, phpmyadmin too :)
On winXP these scripts working fine, in the win2003 with same php and firewall settings not....


???? Abyss Web Server works fine on Windows 2003. Please do not confuse the problem cited above (which is a PHP problem reported as a bug even on PHP official boards) and any setup problem you may have with your computer.

If it does not work on your computer, this does not mean that "it does not work on 2003". There are thousands of people using Abyss on 2003 with no problems.

Now let's be constructive and help us help you by explaining us what this "Does not work" means? Are there error message? What is reported in your log files?

Have you tried using the CGI mode? Does it work?
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
aprelium-beta
-


Joined: 24 Jun 2004
Posts: 383

PostPosted: Mon May 22, 2006 11:49 pm    Post subject: Reply with quote

The new test release 2.3.1.3 ( http://www.aprelium.com/forum/viewforum.php?f=27 ) works fine with PHP 5.1.3 and later when using the FastCGI interface. Ensure that the interface is set to "FastCGI (Local - Pipes)" to have them run flawlessly.
_________________
Beta Testing Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> PHP All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group