error 500 but not error message

 
Post new topic   Reply to topic    Aprelium Forum Index -> PHP
View previous topic :: View next topic  
Author Message
Giu
-


Joined: 20 May 2016
Posts: 2

PostPosted: Tue Dec 06, 2016 9:11 am    Post subject: error 500 but not error message Reply with quote

Hi.

I have deployed Abyss on a w2003 server. all works fine and extremely fast, loving Abyss, but I have one important problem don't know how to solve. I have a PHP page, that process a csv file, to import data into a MySQL database. using WAMP works like a charm, but with Abyss, I get an error 500 after some time the process started to run.

If I check the logs, I don't see errors. AFAIU, a 500 error comes from a syntax or error in code, but the same code runs OK under apache. Some idea what could be the problem? in log, I only see something like

Reading 8 bytes failed = The process cannot access the file because it is being used by another process.
Back to top View user's profile Send private message
Toasty
-


Joined: 21 Feb 2008
Posts: 295
Location: Chicago, IL

PostPosted: Tue Dec 27, 2016 5:37 pm    Post subject: Reply with quote

This is an issue I've had with Abyss so many times, long running processes (DB queries etc).

For something like this, you're better off just running it from the CLI or setting up a scheduled task to process the data, and use the webpage to output the cached version.

Never had the issue with nginx or httpd though.
_________________
Portfolio: Robert Lerner
Back to top View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> PHP All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group