abyss console + stunnel, will it work?

 
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions
View previous topic :: View next topic  
Author Message
hc2995
-


Joined: 07 Aug 2006
Posts: 644
Location: Maryland, USA

PostPosted: Fri Sep 08, 2006 2:25 am    Post subject: abyss console + stunnel, will it work? Reply with quote

ok im on linux ubuntu 6.06 and im trying to insall stunnel but during the ./configure part i get this:

Couldn't find your SSL library installation dir
Use --with-ssl option to fix this problem

so i tried ./configure --with-sll but i get the same problem..... can anyone help?


EDIT: thats fixed i got stunnel working (https:// works) now i want to know if the console will allows SSL connections? If so how do i set it up?
_________________
Where have i been? School got heck-tick, had to move half way around the state, then back... and then i had to change jobs, so iv been away for a while :P


Last edited by hc2995 on Sat Sep 09, 2006 10:18 pm; edited 1 time in total
Back to top View user's profile Send private message AIM Address
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3720
Location: USA, GA

PostPosted: Fri Sep 08, 2006 8:19 am    Post subject: Reply with quote

You need to include the path to OpenSSL. Here's a small example.

./configure --with-ssl=/usr/local/stunnel
_________________
Computer Programmer & Networking Specialist

Back to top View user's profile Send private message Visit poster's website MSN Messenger
hc2995
-


Joined: 07 Aug 2006
Posts: 644
Location: Maryland, USA

PostPosted: Fri Sep 08, 2006 11:19 am    Post subject: Reply with quote

ok i installed opneSSL and did the ./configure --with-ssl=/usr/local/ssl

that went ok till i did make and got this:

/usr/bin/ld: cannot find -lwrap
collect2: ld returned 1 exit status
make[1]: *** [libstunnel.la] Error 1
make[1]: Leaving directory `/home/howard/Desktop/stunnel/src'
make: *** [all-recursive] Error 1
_________________
Where have i been? School got heck-tick, had to move half way around the state, then back... and then i had to change jobs, so iv been away for a while :P
Back to top View user's profile Send private message AIM Address
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Fri Sep 08, 2006 1:28 pm    Post subject: Re: need help with stunnel configureation Reply with quote

hc2995,

Why not installing STunnel using apt-get or the package manager of Ubuntu. It will download the libraries STunnel depends on automatically and you won't have to deal with the build by yourself.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
hc2995
-


Joined: 07 Aug 2006
Posts: 644
Location: Maryland, USA

PostPosted: Fri Sep 08, 2006 7:48 pm    Post subject: Reply with quote

ok so thats:

sudo apt-get install stunnel? or stunnel VERSION?
_________________
Where have i been? School got heck-tick, had to move half way around the state, then back... and then i had to change jobs, so iv been away for a while :P
Back to top View user's profile Send private message AIM Address
hc2995
-


Joined: 07 Aug 2006
Posts: 644
Location: Maryland, USA

PostPosted: Sat Sep 09, 2006 12:12 am    Post subject: Reply with quote

i cant find stunnel in the repository......
_________________
Where have i been? School got heck-tick, had to move half way around the state, then back... and then i had to change jobs, so iv been away for a while :P
Back to top View user's profile Send private message AIM Address
canoedf
-


Joined: 25 Oct 2004
Posts: 13
Location: Colorado

PostPosted: Sat Sep 09, 2006 12:51 am    Post subject: Reply with quote

After you find the packages - maybe this http://www.aprelium.com/forum/viewtopic.php?p=57629#57629
will help

Good luck.....
_________________
Dan
Back to top View user's profile Send private message
hc2995
-


Joined: 07 Aug 2006
Posts: 644
Location: Maryland, USA

PostPosted: Sat Sep 09, 2006 9:13 am    Post subject: Reply with quote

its still not working, heres what it says:

howard@DELL:~/Desktop/stunnel$ make
Making all in src
make[1]: Entering directory `/home/howard/Desktop/stunnel/src'
/bin/sh ../libtool --tag=CC --mode=link gcc -g -O2 -Wall -Wshadow -Wcast-align -Wpointer-arith -I/usr/local/ssl/include -o libstunnel.la -rpath /usr/local/lib -avoid-version env.lo -lz -ldl -lutil -lpthread -L/usr/local/ssl/lib -lssl -lcrypto -lwrap
gcc -shared .libs/env.o -lz -ldl -lutil -lpthread -L/usr/local/ssl/lib -lssl -lcrypto -lwrap -Wl,-soname -Wl,libstunnel.so -o .libs/libstunnel.so
/usr/bin/ld: cannot find -lwrap
collect2: ld returned 1 exit status
make[1]: *** [libstunnel.la] Error 1
make[1]: Leaving directory `/home/howard/Desktop/stunnel/src'
make: *** [all-recursive] Error 1
_________________
Where have i been? School got heck-tick, had to move half way around the state, then back... and then i had to change jobs, so iv been away for a while :P
Back to top View user's profile Send private message AIM Address
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sat Sep 09, 2006 12:43 pm    Post subject: Reply with quote

hc2995 wrote:
/usr/bin/ld: cannot find -lwrap


Install the package libwrap-dev and "remake".
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
hc2995
-


Joined: 07 Aug 2006
Posts: 644
Location: Maryland, USA

PostPosted: Sat Sep 09, 2006 3:03 pm    Post subject: Reply with quote

aprelium wrote:
hc2995 wrote:
/usr/bin/ld: cannot find -lwrap


Install the package libwrap-dev and "remake".


*high five aprelium* YES!

ok i did ./stunnel and i think its started (i didnt get an error) BUT i cant connect to my server with https://127.0.0.1 i printed the sockets and got this:

howard@DELL:~/Desktop/ssl/SSL/src$ ./stunnel -sockets
Socket option defaults:
Option Accept Local Remote OS default
SO_DEBUG -- -- -- 0
SO_DONTROUTE -- -- -- 0
SO_KEEPALIVE -- -- -- 0
SO_LINGER -- -- -- 0:0
SO_OOBINLINE -- -- -- 0
SO_RCVBUF -- -- -- 87380
SO_SNDBUF -- -- -- 16384
SO_RCVLOWAT -- -- -- 1
SO_SNDLOWAT -- -- -- 1
SO_RCVTIMEO -- -- -- 0:0
SO_SNDTIMEO -- -- -- 0:0
SO_REUSEADDR 1 -- -- 0
SO_BINDTODEVICE -- -- -- --
IP_TOS -- -- -- 0
IP_TTL -- -- -- 64
TCP_NODELAY -- -- -- 0
howard@DELL:~/Desktop/ssl/SSL/src$


heres what my conf file looks like:

; Sample stunnel configuration file by Michal Trojnara 2002-2006
; Some options used here may not be adequate for your particular configuration
; Please make sure you understand them (especially the effect of chroot jail)

; Certificate/key is needed in server mode and optional in client mode
cert = /usr/local/etc/stunnel/stunnel.pem
;key = /usr/local/etc/stunnel/mail.pem

; Protocol version (all, SSLv2, SSLv3, TLSv1)
sslVersion = SSLv3

; Some security enhancements for UNIX systems - comment them out on Win32
chroot = /usr/local/var/lib/stunnel/
setuid = nobody
setgid = nogroup
; PID is created inside chroot jail
pid = /stunnel.pid

; Some performance tunings
socket = l:TCP_NODELAY=1
socket = r:TCP_NODELAY=1
;compression = rle

; Workaround for Eudora bug
;options = DONT_INSERT_EMPTY_FRAGMENTS

; Authentication stuff
;verify = 2
; Don't forget to c_rehash CApath
; CApath is located inside chroot jail
;CApath = /certs
; It's often easier to use CAfile
;CAfile = /usr/local/etc/stunnel/certs.pem
; Don't forget to c_rehash CRLpath
; CRLpath is located inside chroot jail
;CRLpath = /crls
; Alternatively you can use CRLfile
;CRLfile = /usr/local/etc/stunnel/crls.pem

; Some debugging stuff useful for troubleshooting
;debug = 7
;output = stunnel.log

; Use it for client mode
client = yes

; Service-level configuration

;[pop3s]
;accept = 995
;connect = 110

;[imaps]
;accept = 993
;connect = 143

;[ssmtp]
;accept = 465
;connect = 25

[https]
accept = 443
connect = 80
TIMEOUTclose = 0
_________________
Where have i been? School got heck-tick, had to move half way around the state, then back... and then i had to change jobs, so iv been away for a while :P
Back to top View user's profile Send private message AIM Address
aprelium-beta
-


Joined: 24 Jun 2004
Posts: 383

PostPosted: Tue Jul 03, 2007 1:58 am    Post subject: Re: abyss console + stunnel, will it work? Reply with quote

Native SSL support is now available. Please check the Beta version of Abyss Web Server 2.5 in http://www.aprelium.com/forum/viewforum.php?f=32 .
_________________
Beta Testing Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group