Newbies guide: PHP, MySQL and phpMyAdmin

 
Post new topic   Reply to topic    Aprelium Forum Index -> Tutorials
View previous topic :: View next topic  
Author Message
Goldmund
-


Joined: 19 Feb 2005
Posts: 19
Location: Seattle, WA

PostPosted: Wed Mar 02, 2005 5:14 am    Post subject: Newbies guide: PHP, MySQL and phpMyAdmin Reply with quote

Hi,

This is a newbies guide to installing and setting up PHP 5.0.3, MySQL 4.0 and phpMyAdmin 2.6.1. I am using Windows XP, by the way.

-Download phpMyAdmin 2.6.1 from http://www.phpmyadmin.net/home_page/downloads.php and follow the tutorial on http://www.trustabyss.com/.
-Download php 5.0.3-Win32.zip from http://www.php.net/downloads.php
*Be sure to download the one that reads: "PHP 5.0.3 zip package", because this is the one that comes with the 'php_mysql.dll' file.
-Follow the tutorial from http://www.trustabyss.com/ to install PHP
-Download the 'Collection of PECL modules for PHP 5.0.3'
*I'm not sure if you really need these, but do it anyway
-Extract these files to the 'C:/PHP/ext' folder
-Download MySQL 4.0 from http://dev.mysql.com/downloads/
-Follow the tutorial from http://www.trustabyss.com/
*When you first run MySQL create a username and password, which will
initiate the 'green light.'
-Go to your php.ini file in the 'C:/WINDOWS' folder and find...

;extension=php_mysql.dll

and change it to...

extension=php_mysql.dll

-Finally find...

extension_dir = "./"

and change it to...

extension_dir = "ext"

-Now if you open your Abyss Web Server Console and type in the URL:
http://127.0.0.1/phpadmin

Tada! You should see phpMyAdmin up and running!

Hope this helps!
_________________
You learn something new every day.
Back to top View user's profile Send private message
Caduceus
-


Joined: 13 Mar 2005
Posts: 21
Location: Chattanooga, TN

PostPosted: Wed Mar 16, 2005 5:34 pm    Post subject: Now Nothing Reply with quote

Hi,

I'm having a terrible time trying to get all three of these programs to work at the same time. I'm running on the following setup:

Sony VAIO (older machine) w/256Mb RAM and Win95
A dedicated 10Gb HD w/Abyss installed
In separate directories on the same drive, PHP and MySQL

I followed TRUSTpunk's tutorial, now I can't get MySQL to work.

There are several things that I need to clarify and maybe you can help.

1) Abyss says it's running on Port 80, but when you look at the url for phpadmin this is what I get

http://127.0.0.1:9999/phpadmin

2) When I go to that url I get a MySQL error

#2003 - The server is not responding

When I click on the link, the info at mysql.com I get the following re: that error code:

Error: 2003 (CR_CONN_HOST_ERROR)

Message: Can't connect to MySQL server on '%s' (%d)

3) I can't get MySQL to restart, although I had it running before I tried to set up phpadmin

Can you help?

Thanks
Back to top View user's profile Send private message Send e-mail Yahoo Messenger MSN Messenger
Goldmund
-


Joined: 19 Feb 2005
Posts: 19
Location: Seattle, WA

PostPosted: Wed Oct 12, 2005 12:10 am    Post subject: Reply with quote

Caduceus, sorry for the long waited reply. I haven't used this forum in a while. Anyway, how are things with your server? Have you got it to work yet?

The first problem I see is is that you are using ":9999" in your URL. Don't do this, just go to http://127.0.0.1/phpadmin and this should work.

Secondly, I know a lot of people have had problems with starting the green light on MySQL. Have you downloaded the PECL modules for PHP and extracted them to the PHP/ext folder?

Also make sure you are downloading the right files for PHP, MySQL and phpMyAdmin (do not install the 'installer' ones, but the zip ones).

I'm installing my server all over again with all the new upgraded programs so I might run into some problems of my own. I wish you luck. Let me know how you are doing.
_________________
You learn something new every day.
Back to top View user's profile Send private message
siralex205
-


Joined: 11 Oct 2005
Posts: 13

PostPosted: Tue Oct 18, 2005 11:37 pm    Post subject: Reply with quote

ok never mind i fixed it..THanks for the tutorial!
Back to top View user's profile Send private message
anumeetsoni
-


Joined: 29 Oct 2005
Posts: 2

PostPosted: Sat Oct 29, 2005 5:47 am    Post subject: Reply with quote

hi ! ur tutorial is good but i am facing a problem.

I have setup Abyss and PHP just fine and they seem to work fine, I tested using a test PHP script.
But i cannot seem to access Mysql from php. Even mysql itself is setup fine
how do i rectify this ?
when i try to run phpMyAdmin i get

"cannot load mysql extension;
please check PHP configuration
Documentation "

and the Abyss icon in system tray blinks with a green rectangle, I checked Php.ini in windows and it has the extension=php_mysql.dll line
plus the extension path is "ext" and i also checked the php install directory has a folder ext with all extensions including php_mysql.dll

I have php version 5.something and Mysql 4.1
Please help
also i tried installing phpBB and even that gave an error saying " your database type is not supported by your server" or something like that ...

Help would be really appreciated..thanx
Back to top View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sat Oct 29, 2005 9:20 am    Post subject: Reply with quote

anumeetsoni wrote:
"cannot load mysql extension;
please check PHP configuration
Documentation "

Check the paths (the extension path) and your php.ini (you may be updating another php.ini file that is not actually used by PHP).
To save your time, we recommend installing our preconfigured PHP5 package from http://www.aprelium.com/abyssws/php5win.html .
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Send e-mail
ladytronica
-


Joined: 08 Dec 2005
Posts: 10

PostPosted: Thu Dec 08, 2005 6:05 am    Post subject: Reply with quote

Okay, I've got Abyss Web Server, PHP5 (the package from here), MySQL and phpMyAdmin setup and everything is good, except for one thing: When I login to phpMyAdmin, I get this error message in red:

Quote:
The mbstring PHP extension was not found and you seem to be using a multibyte charset. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results.


If this is a missing file that PHP/MySQL needs to work, where do I get this from and where do I put it so this error will go away? Please advise, thanks.
_________________
LT
Back to top View user's profile Send private message
ladytronica
-


Joined: 08 Dec 2005
Posts: 10

PostPosted: Thu Dec 08, 2005 6:25 am    Post subject: Reply with quote

Nevermind, I got it to work!

I just forgot to remove the ";" from in front of "extension=php_mbstring.dll" in the "php.ini" file. When I did that and reloaded the page, the error message disappeared.
_________________
LT
Back to top View user's profile Send private message
scorLex
-


Joined: 25 Mar 2006
Posts: 1

PostPosted: Sat Mar 25, 2006 11:48 am    Post subject: Reply with quote

This :?
extension_dir = "C:/Php/ext/"
Back to top View user's profile Send private message
Panda200x
-


Joined: 30 Apr 2006
Posts: 2

PostPosted: Sun Apr 30, 2006 1:48 pm    Post subject: Reply with quote

I tried adding PHP 5
http://www.aprelium.com/abyssws/php5win.html
and now i can't access my server.
What do I do?
Back to top View user's profile Send private message
olly86
-


Joined: 25 Apr 2003
Posts: 993
Location: Wiltshire, UK

PostPosted: Sun Apr 30, 2006 2:29 pm    Post subject: Reply with quote

what error are you getting?

(assuming error 500) most likely php has not been setup correctly, try following the install instructions again.
_________________
Olly
Back to top View user's profile Send private message
AbyssUnderground
-


Joined: 31 Dec 2004
Posts: 3855

PostPosted: Sun Apr 30, 2006 2:35 pm    Post subject: Reply with quote

Panda200x wrote:
I tried adding PHP 5
http://www.aprelium.com/abyssws/php5win.html
and now i can't access my server.
What do I do?


Try following www.abyssunderground.co.uk/tutorials-php.php. Remember that PHP5 uses the executable php-cgi.exe not php.exe.
_________________
Andy (AbyssUnderground) (previously The Inquisitor)
www.abyssunderground.co.uk
Back to top View user's profile Send private message Visit poster's website
will-ko
-


Joined: 23 Aug 2006
Posts: 2

PostPosted: Wed Aug 23, 2006 1:49 am    Post subject: Reply with quote

i just followed the Php tutorial in on that site and im pritty sure it didnt work. help me please :(
Back to top View user's profile Send private message AIM Address MSN Messenger
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3714
Location: USA, GA

PostPosted: Wed Aug 23, 2006 10:35 am    Post subject: Reply with quote

Make sure you save your PHP files in the ANSI encoding. You can do this by
using NotePad. If this doesn't fix the problem, can you post the code you're
using, that way we can give it a test to see if it's working?

Also, what's the version of Abyss Web Server you're using? Are you using the
correct FastCGI for the PHP version? PHP5 needs the "Local Pipes" option for
FastCGI Interface. Please review your settings.
_________________
Computer Programmer & Networking Specialist

Back to top View user's profile Send private message Visit poster's website MSN Messenger
will-ko
-


Joined: 23 Aug 2006
Posts: 2

PostPosted: Wed Aug 23, 2006 2:31 pm    Post subject: Reply with quote

Sorry im new to this...
Could you please give me a little more detail?
Thanks
Back to top View user's profile Send private message AIM Address MSN Messenger
hc2995
-


Joined: 07 Aug 2006
Posts: 644
Location: Maryland, USA

PostPosted: Wed Aug 23, 2006 10:58 pm    Post subject: Reply with quote

switch the order about what to install yours is:
PMA installed first
PHP installed second
MySQL installed last

it should be:

PHP installed first
MySQL installed second
PMa installed last

That way that one person out there dosent try to install PMA then PHP5 then MySQL (couse theres bound to be 1 ;))
_________________
Where have i been? School got heck-tick, had to move half way around the state, then back... and then i had to change jobs, so iv been away for a while :P
Back to top View user's profile Send private message AIM Address
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> Tutorials All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group