Pre-configured php doesnot work with Abyss Web Server X1

 
Post new topic   Reply to topic    Aprelium Forum Index -> PHP
View previous topic :: View next topic  
Author Message
raynet
-


Joined: 20 Dec 2013
Posts: 2

PostPosted: Fri Dec 20, 2013 5:36 pm    Post subject: Pre-configured php doesnot work with Abyss Web Server X1 Reply with quote

Hello,

I have downloaded and installed the latest version of Abyss Web Server X1 2.9
Download Abyss Web Server X1 for Windows (2112 KB)
from http://www.aprelium.com/abyssws/download.php

I have downloaded ans installed the lastest "compatible" version of PHP5 from http://www.aprelium.com/abyssws/php.html
where we read:
If you plan to install PHP 5 on Windows, we highly recommend using our preconfigured PHP 5 package instead of following the generic PHP setup instructions below. It is easier, faster, and less error prone.
I am under windows7 so i downloaded and installed:
If you are using Windows Vista, 7, 8, 8.1, 2008 and 2012 or later, download the preconfigured PHP 5.5.6 package for Windows.

when i try index2.php an html page containing only this:
Your Ip Address is: <strong><?php echo $_SERVER['REMOTE_ADDR']; ?></strong><br><br>

The result is an error page saying:
PHP Startup: PDO: Unable to initialize module
Module compiled with module API= 20060613
PHP compiled with module API=20121212
These options need to match.

Please HELP !
Ray.
Back to top View user's profile Send private message
aprelium-support
-


Joined: 20 Feb 2009
Posts: 356

PostPosted: Sat Jan 18, 2014 9:38 am    Post subject: Re: Pre-configured php doesnot work with Abyss Web Server X1 Reply with quote

raynet,

It seems that you have installed a new PHP5 package over an old one and retained the old php.ini. We recommend installing in a fresh location to avoid such problems or update your php.ini to not load old extensions from the old setup.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Visit poster's website
Gleedaniel13
-


Joined: 25 Jul 2013
Posts: 22

PostPosted: Tue Mar 18, 2014 3:45 pm    Post subject: Reply with quote

Quote:
raynet,

It seems that you have installed a new PHP5 package over an old one and retained the old php.ini. We recommend installing in a fresh location to avoid such problems or update your php.ini to not load old extensions from the old setup.


Are you saying that we should have to reprogram our computer or we just need to create a new folder from the d or c location?
_________________
Web Design Integration
Back to top View user's profile Send private message Visit poster's website
aprelium-support
-


Joined: 20 Feb 2009
Posts: 356

PostPosted: Thu Mar 20, 2014 5:11 pm    Post subject: Reply with quote

Gleedaniel13 wrote:
Are you saying that we should have to reprogram our computer or we just need to create a new folder from the d or c location?


Who said you need to "reprogram your computer"? We only said that you should check the loaded extensions in php.ini and remove those who are old and no more available on newer versions of PHP.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Visit poster's website
Toasty
-


Joined: 21 Feb 2008
Posts: 295
Location: Chicago, IL

PostPosted: Sat Mar 29, 2014 4:08 am    Post subject: Reply with quote

raynet --

What you should do is:

- Stop Abyss
COPY your /php/ directory into a backup directory
- Install/unzip the new version of PHP into the /php/ directory

Then, go through your old and your new PHP.INI, making sure that all options are the same (extensions).

- Start - Run - cmd

Then, navigate to your PHP directory, and simply type "php"

If it just sits there, your PHP is ready to go, if not you'll get an error that you need to fix. If it just sits there, hit Ctrl+C and close cmd.

- Restart Abyss
_________________
Portfolio: Robert Lerner
Back to top View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> PHP All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group