Google Chrome downloading index files?

 
Post new topic   Reply to topic    Aprelium Forum Index -> PHP
View previous topic :: View next topic  
Author Message
lestat
-


Joined: 15 Sep 2003
Posts: 129
Location: GREEN BAY

PostPosted: Thu Aug 22, 2013 2:50 pm    Post subject: Google Chrome downloading index files? Reply with quote

Hi,

I'm running into a strange issue while running chrome 29.0.1547.57 m. It often, but randomly, wants to download php files rather than serving them.

This doesn't happen in any other browsers. I've tried Opera, IE, Maxthon, and Firefox. That being said it sounds like a browser (or plugin) issue to me.

Anyone else running into this?
_________________
XP Pro sp2
Abyss Web Server X2 (v 2.9.3.5)
PHP 5.3.8
Back to top View user's profile Send private message AIM Address MSN Messenger
aprelium-support
-


Joined: 20 Feb 2009
Posts: 356

PostPosted: Fri Aug 23, 2013 7:25 pm    Post subject: Re: Google Chrome downloading index files? Reply with quote

lestat,

This is actually a bug in Chrome which affects randomly some pages and some setups.

The bug is filed in https://code.google.com/p/chromium/issues/detail?id=246875 and the discussion about it is in http://productforums.google.com/forum/#!topic/chrome/zID6uQQfKH8.

Fortunately, some Chrome developers seem to have acknowledged that there was a change in the behavior of the browser with cached 304 requests which is exactly what we've suspected in our earlier email exchanges.

So if there will be nothing fixed in the coming weeks, we'll probably blacklist Chrome as unable to handle 304 correctly in the console (and probably in the Web sites even though this may cause us a lot of trouble with some customers.)
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Visit poster's website
lestat
-


Joined: 15 Sep 2003
Posts: 129
Location: GREEN BAY

PostPosted: Mon Aug 26, 2013 3:13 pm    Post subject: Reply with quote

Good to know you guys (as usual) are on the case!
_________________
XP Pro sp2
Abyss Web Server X2 (v 2.9.3.5)
PHP 5.3.8
Back to top View user's profile Send private message AIM Address MSN Messenger
Toasty
-


Joined: 21 Feb 2008
Posts: 295
Location: Chicago, IL

PostPosted: Fri Dec 27, 2013 7:25 am    Post subject: Reply with quote

I suspect there is some strange interaction with AWS and caching headers, at least in 2.7. I often times see my CSS failing to load since AWS rejects returning the document when it feels the cache should be warmed up.

I haven't done much digging into the actual session, but I've seen it a few times now.
_________________
Portfolio: Robert Lerner
Back to top View user's profile Send private message Visit poster's website
aprelium-support
-


Joined: 20 Feb 2009
Posts: 356

PostPosted: Sat Jan 18, 2014 9:39 am    Post subject: Reply with quote

A quick update about that issue: We've made a lot of progress and we have now a fixed version that worked fine for a few weeks without exhibiting these issues.

Early testers that would like to give it a try can contact us to get it as soon as it will be released.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> PHP All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group