Can't Connect Over LAN

 
Post new topic   Reply to topic    Aprelium Forum Index -> Networking Issues
View previous topic :: View next topic  
Author Message
shacho
-


Joined: 27 Apr 2009
Posts: 2

PostPosted: Mon Apr 27, 2009 7:47 am    Post subject: Can't Connect Over LAN Reply with quote

I have just installed the web server and it is running. If I try to connect from the host machine to the host machine at http://localhost/ , my test page is received correctly. If I try to connect from the the host machine to the host machine using the host machine's Ethernet address instead of localhost, I am also successful in loading the test page. However, if I try to connect from another machine on the LAN to the host machine using the host machine's Ethernet address, the connection times out. Here is a summary of what I have tried and what works and doesn't work:

HM = Host Machine, RM = Remote Machine.

HM ->HTTP-> HM:localhost : OK
HM ->HTTP-> HM:Ethernet Address : OK
RM ->HTTP-> HM:Ethernet Address : Fail
RM ->PING-> HM:Ethernet Address : OK
RM ->Telnet Port 80 -> HM:Ethernet Address : OK

Firewall on host machine is disabled. All machines are on the same subnet with same default gateway.

Any ideas?


Mike
Back to top View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 876
Location: Michigan, USA

PostPosted: Mon Apr 27, 2009 2:22 pm    Post subject: Reply with quote

That's very strange!

One more test you could try from the remote machine. What's your server's network name? If it's myserver, go to your browser and type in http://myserver and it should bring up the site. Does that time out too? Then if you have files and folders shared on the server, go to Windows Explorer and type in \\myserver and see if it gives you any errors.

Another quick thought popped into my head. Does your server have a staticly-assigned IP address (in your LAN)? If not, maybe there's a DHCP issue with the router. See if anything changes by rebooting the router. If not, assign a static IP addy to the server.
_________________
Stephen
Need a LitlURL?


http://CodeBin.yi.org
Back to top View user's profile Send private message Visit poster's website
shacho
-


Joined: 27 Apr 2009
Posts: 2

PostPosted: Mon Apr 27, 2009 2:30 pm    Post subject: Reply with quote

pk - thanks for your comment. To my shame, I've just traced the problem to a mindless oversight. Proxy exception was wrong.

Mike
Back to top View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> Networking Issues All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group