installing wwwboard

 
Post new topic   Reply to topic    Aprelium Forum Index -> Perl
View previous topic :: View next topic  
Author Message
toomyg155
-


Joined: 03 May 2007
Posts: 47

PostPosted: Thu May 03, 2007 10:50 pm    Post subject: installing wwwboard Reply with quote

Im trying to install the wwwboard with Abyss Web Server X1 (v 2.4) I went by the book on installing perl declaring index files and soforth here http://www.aprelium.com/abyssws/perl.html and went by the book on installing the wwwboard but it still won't work and I get error 500 and here is the error I get from the cgi log



"CGI: [C:\Perl\bin\perl.exe wwwboard.pl ] URI: /cgi-bin/wwwboard.pl Broken pipe
No such file or directory at wwwboard.pl line 263."

I dont know if chmodding has anything to do with it because I have know why to change it but can anyone tell me what I am doing wrong???
other then this message board problem my web page works great

Please
Back to top View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 873
Location: Michigan, USA

PostPosted: Fri May 04, 2007 2:33 am    Post subject: Reply with quote

I assume you're referring to this line:
Code:
   open(NEWFILE,">$basedir/$mesgdir/$num\.$ext") || die $!;


Make sure all the variables have a valid value. It's trying to create the message html file. It's stored in the /msg folder. Make sure this subfolder exists.
_________________
Stephen
Need a LitlURL?


http://CodeBin.yi.org
Back to top View user's profile Send private message Visit poster's website
toomyg155
-


Joined: 03 May 2007
Posts: 47

PostPosted: Fri May 04, 2007 1:14 pm    Post subject: Reply with quote

All the directorys are there and I made sure all the settings were the way they should be here afre the settings


$basedir = "F:\htdocs\wwwboard";
$baseurl = "http://192.168.1.125/wwwboard";
$cgi_url = "http://192.168.1.125/wwwboard/wwwboard.cgi";

$mesgdir = "http://192.168.1.125/wwwboard/messages";
$datafile = "http://192.168.1.125/wwwboard/data.txt";
$mesgfile = "http://192.168.1.125/wwwboard/wwwboard.html";
$faqfile = "http://192.168.1.125/wwwboard/faq.html";

and here is the error I am getting now in the cgi log
Invalid argument at wwwboard.cgi line 263.
CGI: [C:\Perl\bin\perl.exe wwwboard.cgi ] URI: /wwwboard.cgi Broken pipe

and I am still getting the error 500 Internal Server Error no matter what I do and by the way the OS is windows 2000 pro if that matters
Back to top View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 873
Location: Michigan, USA

PostPosted: Fri May 04, 2007 1:36 pm    Post subject: Reply with quote

Here's part of my config:
Code:
$mesgdir = "messages";
$datafile = "data.txt";
$mesgfile = "4LBL_board.htm";
$faqfile = "faq.htm";


Notice $mesgdir is a file reference, not a URL.
Same with $datafile, $mesgfile, and $faqfile.

That would explain why Perl has a filesystem error!
_________________
Stephen
Need a LitlURL?


http://CodeBin.yi.org
Back to top View user's profile Send private message Visit poster's website
toomyg155
-


Joined: 03 May 2007
Posts: 47

PostPosted: Fri May 04, 2007 2:03 pm    Post subject: Reply with quote

I changed it but it still does the same thing
Back to top View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 873
Location: Michigan, USA

PostPosted: Fri May 04, 2007 3:03 pm    Post subject: Reply with quote

Try changing $base_dir to F:/htdocs/wwwboard
Perl might like it better :)

You might also see if Win2000 blocks writing access to the messages folder. Try creating a file named 1.htm.

BTW, I've used WinXP and Win98 with wwwboard and have had no problems.
_________________
Stephen
Need a LitlURL?


http://CodeBin.yi.org
Back to top View user's profile Send private message Visit poster's website
toomyg155
-


Joined: 03 May 2007
Posts: 47

PostPosted: Fri May 04, 2007 4:09 pm    Post subject: Reply with quote

NO it still does not work I can make the name1.htm in the messages folder with no problem and I checked the folder permissions and everyone was selected but how do I check writing access
Back to top View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 873
Location: Michigan, USA

PostPosted: Fri May 04, 2007 4:33 pm    Post subject: Reply with quote

Save this as makefile.cgi in the wwwboard dir. It will create wwwboard/messages/myhtml.html.

Code:
#!/usr/bin/perl
use Fcntl; #The Module

print "content-type: text/html \n\n"; #The header
sysopen (HTML, './messages/myhtml.html', O_RDWR|O_EXCL|O_CREAT, 0755);
printf HTML "<html>\n";
printf HTML "<head>\n";
printf HTML "<title>My Home Page</title>";
printf HTML "</head>\n";
printf HTML "<body>\n";
printf HTML "<p align='center'>Here we have an HTML
page with a paragraph.</p>";
printf HTML "</body>\n";
printf HTML "</html>\n";
close (HTML);
print "HTML file should be written.";


Just check if the file exists in the messages folder.
_________________
Stephen
Need a LitlURL?


http://CodeBin.yi.org
Back to top View user's profile Send private message Visit poster's website
toomyg155
-


Joined: 03 May 2007
Posts: 47

PostPosted: Fri May 04, 2007 5:11 pm    Post subject: Reply with quote

Yes it did work!!!!!


I also found a message board located here also called WWWBOARD
http://nms-cgi.sourceforge.net/scripts.shtml
and it did the same thing

Don't I have to chmod the files? if so how do I do that
Back to top View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 873
Location: Michigan, USA

PostPosted: Fri May 04, 2007 5:59 pm    Post subject: Reply with quote

Well, the problem is not with Perl writing files. Chmodding is not your problem (that's Unix-specific - http://en.wikipedia.org/wiki/Chmod). It must be your configuration file for WWWboard.
BTW, the site you listed gives the exact same script.

You can email or PM me your wwwboard.pl file and I'll look over it for errors if you want.
_________________
Stephen
Need a LitlURL?


http://CodeBin.yi.org
Back to top View user's profile Send private message Visit poster's website
cagozoe
-


Joined: 24 Apr 2005
Posts: 23

PostPosted: Tue Jul 03, 2007 9:46 pm    Post subject: wwwboard i have it working Reply with quote

If you would like to see and need a copy i can send you one.

http://www.cvb.dns2go.com/gandm/board/godword.html
Back to top View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> Perl All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group