Installation problem

 
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions
View previous topic :: View next topic  
Author Message
fhutt
-


Joined: 14 Jul 2019
Posts: 41

PostPosted: Fri Feb 12, 2021 4:47 am    Post subject: Installation problem Reply with quote

Hello,
I have been using Abbys for a while and has worked fine.
However, something has happened and the server is now stopping with a window at startup with this message:

"The data is invalid. (key: root/certificates/acme/logfile - file: C:\Program Files (x86)\Abyss Web Server\abyss.conf - line: 542 - col: 3)
The operation completed successfully. (key: root/certificates/acme/proxy/type - file: C:\Program Files (x86)\Abyss Web Server\abyss.conf - line: 0 - col: 0)
The data is invalid. (file: C:\Program Files (x86)\Abyss Web Server\persist.data - line: 0 - col: 0)
Cannot save the persistant data (file: C:\Program Files (x86)\Abyss Web Server\persist.data - line: 0 - col: 0)
The console is not running"

Whenever, I try to launch the server I get this same message.

I tried to reinstall it (a number of times) with the same result. Each time it states that it is upgrading to a new version.

Is it possible to uninstall it without losing the settings. Maybe a fresh install keeping the settings would work.
Could someone please help?
Thanks

Edit: I found a virus on the system. Now that it is removed, the installation works. No longer have the problem.
Back to top View user's profile Send private message
fhutt
-


Joined: 14 Jul 2019
Posts: 41

PostPosted: Fri Feb 12, 2021 9:43 pm    Post subject: Reply with quote

I was mistaken saying that the problem is solved.
The installation worked until a reboot. Then the same with the error message.
Reinstalling works at times, but upon a reboot seems to fail.

So, I am still trying to do a clean install but keeping the settings. How would this be possible?
Thanks
Back to top View user's profile Send private message
admin
Site Admin


Joined: 03 Mar 2002
Posts: 1105

PostPosted: Wed Feb 17, 2021 11:27 pm    Post subject: Re: Installation problem Reply with quote

fhutt,

We noticed that your message references C:\Program Files (x86)\Abyss Web Server as the installation path of Abyss Web Server.

Please use the default for installing Abyss Web Server. We mean use the default as offered by the installer : C:\Abyss Web Server

Modern versions of Windows have a special processing of files inside C:\Program Files (x86) and this directory is now only good for storing read-only files. Abyss Web Server as any server software requires a "directory" where it can write and store its configuration and this cannot be made inside C:\Program Files (x86)\.

So please install Abyss Web Server inside C:\Abyss Web Server or any other "user controlled" path on your hard drive. Stay away from "Program files" and any Windows system directory.
_________________
Follow @abyssws on Twitter
Subscribe to our newsletter
_________________
Forum Administrator
Aprelium - https://aprelium.com
Back to top View user's profile Send private message
fhutt
-


Joined: 14 Jul 2019
Posts: 41

PostPosted: Wed Feb 17, 2021 11:59 pm    Post subject: Reply with quote

Thank you for your explanation.

While looking for the virus I changed my virus checher. In removing the virus I had to do a boot virus scan. For some reason during that process my user rights changed. I was no longer an administrator on my computer. I also found other programs not working properly.

I added myself to the administrators group but didn't fix the problems.
I did a system restore to an earlier system and that now has repaired all the problems (I am in the administrator group as well as the user group).

Yes, the Abbys server is located in "C:\Program Files (86)". I don't recall installing it in a non default location (maybe I am mistaken but never received a message during reinstalls or updates that it is in the wrong place). It's good to know for the future, that this may be a problem.

Years ago, I tried to use the computer with non admin user rights, but it was too difficult.

Now, I use stripmyrights.exe to launch my browser and email client to interface with the web with reduced rights. I also reverted back to use Avast as my virus checker. This protocol has been successful for a long time until now. I am not aware of another simple solution to virus problems.
Back to top View user's profile Send private message
admin
Site Admin


Joined: 03 Mar 2002
Posts: 1105

PostPosted: Sat Feb 20, 2021 8:59 pm    Post subject: Reply with quote

You're welcome.
_________________
Follow @abyssws on Twitter
Subscribe to our newsletter
_________________
Forum Administrator
Aprelium - https://aprelium.com
Back to top View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group