Delayed HTTP_BASE_AUTH prompt

 
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions
View previous topic :: View next topic  
Author Message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Wed Jun 01, 2016 3:07 pm    Post subject: Delayed HTTP_BASE_AUTH prompt Reply with quote

If I enable HTTP_BASE_AUTH on my site, browser wait for about 15 secs to login/password dialog is diplayed. Whan autorization is disabled, pages loading immediatelly. Authentication is group base (one group is ALLOWED) and there is 3 USERS in this group. Do you have idea what could case this behaviour?

X1 2.11.1

Capture packets: http://picpaste.com/screen-JdvRpx1M.png

L.
Back to top View user's profile Send private message
admin
Site Admin


Joined: 03 Mar 2002
Posts: 821

PostPosted: Wed Jun 01, 2016 5:53 pm    Post subject: Re: Delayed HTTP_BASE_AUTH prompt Reply with quote

lazna,

Is there a script or a Web application that is generating the error page? It could explain the long loading time.

Anyway, we suggest sending to our support by email your abyss.conf file as well as a sample URL that triggers such a behavior.
_________________
Follow @abyssws on Twitter
Subscribe to our newsletter
_________________
Forum Administrator
Aprelium - https://aprelium.com
Back to top View user's profile Send private message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Sun Jun 19, 2016 9:41 pm    Post subject: Reply with quote

There is not any error page, when I want to access to virtual directory which is protected by Abyss built-in authentication, it takes about 15 seconds before HTTP_AUTH prompt is displayed. Abyss running on localhost so there is no network delay, PC is powerfull any other requests are served immediatelly. Delay is very probably caused by Abyss SW itself.

Conf file just sent to support mail.

L.
Back to top View user's profile Send private message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Sat Jun 25, 2016 3:26 pm    Post subject: Reply with quote

Any updates ??
Back to top View user's profile Send private message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Tue Jul 26, 2016 9:20 am    Post subject: Reply with quote

Do you have any informations in this issue for me, please?
Back to top View user's profile Send private message
admin
Site Admin


Joined: 03 Mar 2002
Posts: 821

PostPosted: Fri Oct 07, 2016 12:56 pm    Post subject: Reply with quote

lazna wrote:
Do you have any informations in this issue for me, please?


Not really. We have reopened the ticket for our developers.
_________________
Follow @abyssws on Twitter
Subscribe to our newsletter
_________________
Forum Administrator
Aprelium - https://aprelium.com
Back to top View user's profile Send private message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Sun Dec 04, 2016 2:03 am    Post subject: Reply with quote

Hi, any update with this issue? It`s annoyning........

L.
Back to top View user's profile Send private message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Mon Dec 19, 2016 10:51 pm    Post subject: Reply with quote

Just move application from X1 testing server to X2 production server, and discovery that here is no such delay.
Back to top View user's profile Send private message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Thu Mar 09, 2017 8:31 pm    Post subject: Reply with quote

Any updates on this issue?
Back to top View user's profile Send private message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Fri May 12, 2017 10:11 am    Post subject: Reply with quote

Haloooooo
Back to top View user's profile Send private message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Sat Sep 30, 2017 4:18 pm    Post subject: Still nothing??? Reply with quote

Haloooooo
Back to top View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 881
Location: Michigan, USA

PostPosted: Tue Oct 10, 2017 4:28 am    Post subject: Reply with quote

I've never encountered issues with HTTP basic authentication. It's always immediate. Is your issue consistent when using different browsers, perhaps even telnet?

Also, might there be an allow/deny conflict with your users? Just throwing out a few ideas.
_________________
Stephen
Need a LitlURL?


http://CodeBin.yi.org
Back to top View user's profile Send private message Visit poster's website
annakieu541
-


Joined: 25 Jun 2018
Posts: 3

PostPosted: Mon Jun 25, 2018 7:54 am    Post subject: Reply with quote

Any updates ??
Back to top View user's profile Send private message Visit poster's website
admin
Site Admin


Joined: 03 Mar 2002
Posts: 821

PostPosted: Tue Jun 26, 2018 5:44 pm    Post subject: Reply with quote

annakieu541 wrote:
Any updates ??


Are you still suffering the same issue? If so, on which exact version? Is it X1 or X2?
_________________
Follow @abyssws on Twitter
Subscribe to our newsletter
_________________
Forum Administrator
Aprelium - https://aprelium.com
Back to top View user's profile Send private message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Tue Sep 11, 2018 11:38 am    Post subject: Reply with quote

Version X1 2.11.8 - problem still persist.

using wbox tool http://www.hping.org/wbox/ perform same behaviour:

0. 401 Unauthorized 582 bytes 16025 ms
1. 401 Unauthorized 582 bytes 16020 ms
2. 401 Unauthorized 582 bytes 16020 ms
3. 401 Unauthorized 582 bytes 16032 ms
4. 401 Unauthorized 582 bytes 16020 ms
5. 401 Unauthorized 582 bytes 16018 ms
6. 401 Unauthorized 582 bytes 16021 ms
7. 401 Unauthorized 582 bytes 16021 ms
8. 401 Unauthorized 582 bytes 16022 ms

Once browser succesfully perform HTTP_BASE_AUTH, problem disappear. If perform unsuccessful AUTH (provide wrong password) browser wait another few seconds before display AUTH prompt again. Machine load is about 15%.

L.
Back to top View user's profile Send private message
admin
Site Admin


Joined: 03 Mar 2002
Posts: 821

PostPosted: Fri Sep 14, 2018 6:15 pm    Post subject: Reply with quote

lazna,

Sorry if that bug resurfaced again. Could you please send us your updated abyss.conf file for review? What was the exact URL you used for testing?
_________________
Follow @abyssws on Twitter
Subscribe to our newsletter
_________________
Forum Administrator
Aprelium - https://aprelium.com
Back to top View user's profile Send private message
lazna
-


Joined: 16 Aug 2015
Posts: 24

PostPosted: Wed Oct 03, 2018 12:59 pm    Post subject: Reply with quote

admin wrote:
lazna,

Sorry if that bug resurfaced again. Could you please send us your updated abyss.conf file for review? What was the exact URL you used for testing?


http://domain.host.com/directory/

(Real public access URL could be posted by mail if necessary)

My abyss.conf file (<users></users> section cutted):

<?xml version="1.0" encoding="UTF-8"?>
<root>
<server>
<parameters>
<root>
C:\Abyss Web Server
</root>
<timeout>
30
</timeout>
<maxconn>
20
</maxconn>
<keepalive>
10
</keepalive>
<opsys>
<pidfile>
log/abyssws.pid
</pidfile>
</opsys>
</parameters>
<host>
<names/>
<path>
C:\work\wwwroot
</path>
<running>
yes
</running>
<id>
1
</id>
<scripting>
<enabled>
yes
</enabled>
<cgi>
<timeout>
60
</timeout>
<useregistry>
no
</useregistry>
<useshebang>
no
</useshebang>
<errorfile>
log/cgi.log
</errorfile>
</cgi>
<isapi>
<ext>
dll
</ext>
<errorfile>
log/isapi.log
</errorfile>
<debuglevel>
0
</debuglevel>
</isapi>
<fastcgi>
<errorfile>
log/fastcgi.log
</errorfile>
<timeout>
240
</timeout>
<debuglevel>
1
</debuglevel>
<iotimeout>
60
</iotimeout>
</fastcgi>
<interpreters>
<interpreter>
<ext>
CMD
</ext>
<interface>
0
</interface>
<file>
C:\utils\batwrap.exe
</file>
<checkexists>
no
</checkexists>
<type>
0
</type>
<updatepaths>
yes
</updatepaths>
</interpreter>
</interpreters>
<paths>
<path>
<vpath>
/proton
</vpath>
<type>
0
</type>
<xsendfile>
no
</xsendfile>
<outputbuffersize>
0
</outputbuffersize>
</path>
<path>
<vpath>
/watch
</vpath>
<type>
0
</type>
<xsendfile>
no
</xsendfile>
<outputbuffersize>
0
</outputbuffersize>
</path>
<path>
<vpath>
/monitor
</vpath>
<type>
0
</type>
<xsendfile>
no
</xsendfile>
<outputbuffersize>
0
</outputbuffersize>
</path>
</paths>
</scripting>
<ssi>
<extensions>
<ext>
shtml
</ext>
</extensions>
<enabled>
yes
</enabled>
<errormessage/>
<timeformat/>
<abbreviatesize>
yes
</abbreviatesize>
<execcmd>
yes
</execcmd>
</ssi>
<log>
<file>
log/access.log
</file>
<denied/>
<format>
.combined
</format>
</log>
<indexes>
<index>
index.html
</index>
<index>
search.cmd
</index>
<index>
default.aspx
</index>
</indexes>
<antileech>
<paths/>
<redirect/>
<strict>
no
</strict>
<allowed/>
</antileech>
<bindip>
*
</bindip>
<dirlist>
<type>
0
</type>
<scope>
<order>
ad
</order>
<allow>
<path>
/
</path>
</allow>
</scope>
<hidden>
<file>
.*
</file>
</hidden>
</dirlist>
<port>
80
</port>
<compress>
<level>
6
</level>
<scope>
<allow>
<path>
/
</path>
</allow>
<order>
ad
</order>
</scope>
<mimes>
<allow>
<mime>
text/*
</mime>
</allow>
</mimes>
</compress>
<http>
<customheaders>
<header>
<path>
/proton
</path>
<name>
text/html;charset
</name>
<value>
utf-8
</value>
</header>
</customheaders>
<ifmodified/>
</http>



<groups>
<group>
<members>
<user>
xxxxx
</user>
<user>
slavka
</user>
<user>
schum
</user>
<user>
magda
</user>
<user>
sylva
</user>
</members>
<name>
protonet
</name>
</group>
<group>
<members>
<user>
xxxxx
</user>
</members>
<name>
monitor
</name>
</group>
</groups>
<aliases>
<alias>
<virtual>
/proton
</virtual>
<real>
C:\work\wwwroot\proton
</real>
</alias>
<alias>
<virtual>
/rrdtool
</virtual>
<real>
C:\work\rrdtool
</real>
</alias>
<alias>
<virtual>
/watch
</virtual>
<real>
C:\work\wwwroot\watch
</real>
</alias>
<alias>
<virtual>
/monitoring
</virtual>
<real>
C:\work\wwwroot\monitoring
</real>
</alias>
<alias>
<virtual>
/test
</virtual>
<real>
C:\work\wwwroot\test
</real>
</alias>
</aliases>
<ac>
<rules>
<rule>
<allow>
<group>
protonet
</group>
</allow>
<path>
/proton
</path>
<realm>
LOGIN
</realm>
<order>
ad
</order>
</rule>
</rules>
</ac>
<secureport/>
<certificate/>
<ciphers>
RC4-SHA:HIGH:MEDIUM:LOW:DEFAULT:-EXP:!SSLv2:!ADH:!aNULL:!eNULL:!NULL
</ciphers>
<customerrors>
<errors>
<error>
<status>
401
</status>
<url>
/proton/logout.cmd
</url>
</error>
</errors>
</customerrors>
</host>
<throttle>
<maxspeed/>
<maxspeedperip/>
</throttle>
<antihack>
<enabled>
no
</enabled>
<threshold>
20
</threshold>
<monitorperiod>
20
</monitorperiod>
<banperiod>
60
</banperiod>
<logfile/>
<denied>
<ip>
127.0.0.1
</ip>
<ip>
::1
</ip>
</denied>
</antihack>
<mimes>
<useinternal>
yes
</useinternal>
</mimes>
</server>
<version>
2.11.8
</version>
<console>
<port>
9999
</port>
<bindip>
*
</bindip>
<ipcontrol>
<order>
ad
</order>
<allow>
192.168.0.1-192.168.255.254
</allow>
<allow>
172.16.0.1-172.31.255.254
</allow>
<allow>
10.0.0.1-10.255.255.254
</allow>
<allow>
fc00::/7
</allow>
<allow>
fe80::/10
</allow>
</ipcontrol>
<language>
en
</language>
<login>
admin
</login>
<password>
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
</password>
</console>
<certificates>
<pkeys>
<pkey>
<name>
generic
</name>
<file>
542c2823.key
</file>
</pkey>
</pkeys>
<certs>
<cert>
<name>
Certificate
</name>
<pkey>
generic
</pkey>
<file>
542c28f0.crt
</file>
</cert>
</certs>
<csr>
<commonname>
PN
</commonname>
<organization>
Hallo
</organization>
<organizationunit>
COM
</organizationunit>
<locality>
Guycity
</locality>
<stateprovince>
Earth
</stateprovince>
<country>
COM
</country>
<email>
box@host.com
</email>
</csr>
</certificates>
</root>
Back to top View user's profile Send private message
admin
Site Admin


Joined: 03 Mar 2002
Posts: 821

PostPosted: Sat Oct 06, 2018 12:22 am    Post subject: Reply with quote

lazna wrote:
(Real public access URL could be posted by mail if necessary)


We'd appreciate if you send us your abyss.conf file by email as well as the exact URL that exhibits this issue. Many thanks in advance.
_________________
Follow @abyssws on Twitter
Subscribe to our newsletter
_________________
Forum Administrator
Aprelium - https://aprelium.com
Back to top View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group