Search found 7 matches
Aprelium Forum Index
Author Message
  Topic: DotNet Web Service
aflynt

Replies: 5
Views: 25966

PostForum: ASP.NET   Posted: Sun Mar 23, 2008 8:11 pm   Subject: Re: DotNet Web Service
My hypothesis is that the ASP.NET hosting process ignores the first header after the request. I've confirmed this behavior while troubleshooting my own issues with Request.UserAgent. Try sending a req ...
  Topic: Request.UserAgent OSX Safari Empty
aflynt

Replies: 11
Views: 36436

PostForum: ASP.NET   Posted: Wed Mar 19, 2008 11:14 pm   Subject: RE: Different browsers
Not that this problem shouldn't be addressed, but have you considered modifying your website to work with all browsers from a single code base instead of having multiple versions?

Yes. Differing (o ...
  Topic: Request.UserAgent OSX Safari Empty
aflynt

Replies: 11
Views: 36436

PostForum: ASP.NET   Posted: Wed Mar 19, 2008 9:50 pm   Subject: It's a bug in the ASP.NET hosting process
I've found this post in your bug reports forum that isolates the issue:

http://www.aprelium.com/forum/viewtopic.php?t=12670

The problem is that the ASP.NET hosting process ignores the first head ...
  Topic: Request.UserAgent OSX Safari Empty
aflynt

Replies: 11
Views: 36436

PostForum: ASP.NET   Posted: Wed Mar 19, 2008 8:49 pm   Subject: Test Case and bug reduction
I've reduced the bug to the following reproducible behavior:

1. Install the AbyssWeb server X1 and configure a site on it with ASP.NET 2.0 support.
2. Create a file with the following code and sav ...
  Topic: Request.UserAgent OSX Safari Empty
aflynt

Replies: 11
Views: 36436

PostForum: ASP.NET   Posted: Wed Mar 19, 2008 7:37 pm   Subject: Reporting bugs
The problem is not Abyss Web Server here. The HTTP specification does not force any order on the headers. It is a bug in the client here and we suggest that you file a bug report and ask them to fix t ...
  Topic: Request.UserAgent OSX Safari Empty
aflynt

Replies: 11
Views: 36436

PostForum: ASP.NET   Posted: Tue Mar 18, 2008 8:17 pm   Subject: Figured out why, but not how to fix
Hello,

I played around with requests with Wireshark to figure out what headers send by the web browser to Abyss cause the UserAgent to be empty, and I've narrowed it down to this:

If the web bro ...
  Topic: Request.UserAgent OSX Safari Empty
aflynt

Replies: 11
Views: 36436

PostForum: ASP.NET   Posted: Sat Mar 08, 2008 7:14 pm   Subject: Request.UserAgent OSX Safari Empty
When using Safari 3.0.4 on Mac OSX 10.5.2, the HttpContext.Current.Request.UserAgent string is empty. Firefox 2.0.0.12 on OSX 10.5.2 reports the correct info, though. Running the same code under iis ...
 
Page 1 of 1
All times are GMT + 1 Hour
Jump to:  


Powered by phpBB phpBB Group